Bug 1004021 - document blkid -w behaviour
document blkid -w behaviour
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: util-linux-ng (Show other bugs)
6.4
x86_64 Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Karel Zak
Branislav Blaškovič
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 13:44 EDT by agilmore2
Modified: 2014-10-14 03:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: util-linux-ng-2.17.2-12.16.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:34:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description agilmore2 2013-09-03 13:44:55 EDT
Description of problem:
blkid writes to default cache file, even when directed to write elsewhere

Version-Release number of selected component (if applicable):
2.17.2-12.9.el6_4.3

How reproducible:
every time

Steps to Reproduce:
$ sudo rm /etc/blkid/blkid.tab*
$ sudo blkid /dev/sda1 -w /dev/null -o value -s UUID
<UUID> is printed
$ cat /etc/blkid/blkid.tab 
<device DEVNO="0x0801" TIME="1378230067.254175" UUID="<UUID>" TYPE="ext4">/dev/sda1</device>

Actual results:
/etc/blkid/blkid.tab is created with a row for device requested

Expected results:
because -w /dev/null was specified, no cache should have been written

Additional info:
as a workaround, specifying -c /dev/null to not read the cache at all will prevent writing
Comment 2 Karel Zak 2013-09-03 14:35:45 EDT
This feature has never been implemented and the latest blkid versions (rhel7 and fedora) do not support -w at all.

Maybe we can update RHEL6 blkid.8 man page to document this behaviour. I don't think it make sense to do anything else. Sorry.
Comment 6 errata-xmlrpc 2014-10-14 03:34:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1545.html

Note You need to log in before you can comment on or make changes to this bug.