Bug 1004051 - Remote-Viewer: Zoom Out Behavior Is Not Consistent
Remote-Viewer: Zoom Out Behavior Is Not Consistent
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.4
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jonathon Jongsma
Virtualization Bugs
:
Depends On:
Blocks: 1022404
  Show dependency treegraph
 
Reported: 2013-09-03 15:16 EDT by Vimal Patel
Modified: 2014-10-14 02:29 EDT (History)
12 users (show)

See Also:
Fixed In Version: virt-viewer-0.6.0-4.el6
Doc Type: Bug Fix
Doc Text:
Zooming in and out on a window in virt-viewer/remote-viewer would sometimes cause the guest display to be resized rather than simply scaling the local display. After this change, the guest display will never be resized in response to zooming in or out in the client (view > zoom > zoom in / zoom out). It will simply scale the display up or down.
Story Points: ---
Clone Of:
: 1022404 (view as bug list)
Environment:
Last Closed: 2014-10-14 02:29:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vimal Patel 2013-09-03 15:16:12 EDT
Description of problem:
The behavior of zooming out of a RHEL guest is inconsistent.  Most of the time the way zooming out behaves is: The resolution of the guest stays the same, and the geometry or window size of the remote-viewer window decreases.

However, occasionally (1/4 times?) when zooming out the guest's resolution changes and the window size decreses.  This seems to happen more when trying to zoom out multiple times in a row.

An automated test caught this issue, it can be reproduced manually and it look like the following:

1024x768 [Zoom In] ->
1024x768 [Zoom In] ->
1024x769 (Guest Resolution Changed?) [Zoom In] ->
1024x768 (Guest Resolution Changed again, back to original?) [Zoom In] ->
1023x768 [Changed Again?]

Version-Release number of selected component (if applicable):
Host:
spice-server 0.12.0-12,ek6_4.2
qemu-kvm 0.12.1.2-2.355.el6_4.7
libvirt 0.10.2-18.el6_4.9

Client:
spice-vdagent 0.12.0-4.el6
spice-xpi 2.7-22.el6
spice-gtk 0.14-7.el6
spice-glib 0.14-7.el6
virt-viewer 0.5.2-18.el6

Guest:
spice-vdagent 0.12.0-4.el6
spice-gtk 0.14-7.el6
spice-glib 0.14-7.el6
xorg-x11-drv-qxl 0.1.0-4.el6

How reproducible:
33% of time

Steps to Reproduce:
1.
2.
3.

Actual results:
resolution of the guest changes.

Expected results:
resolution of the guest doesn't change by zooming

Additional info:
Comment 2 tingting zheng 2013-10-23 04:27:13 EDT
I can reproduce this issue with:
virt-viewer-0.5.6-8.el6.x86_64

The original resolution of the guest is 1280x768,when zoom out several times,it will changed.

1280x768 [Zoom out] ->
1280x768 [Zoom out] ->
1280x769 [Zoom out] -> Resolution changed.
1280x768 [Zoom out] -> Resolution back to original.
Comment 4 Jonathon Jongsma 2014-02-26 15:24:51 EST
fixed upstream in 895ef8029e794e7b74a45f27c7c741d1332bc02b
Comment 6 Jonathon Jongsma 2014-06-03 10:54:08 EDT
(In reply to Jonathon Jongsma from comment #4)
> fixed upstream in 895ef8029e794e7b74a45f27c7c741d1332bc02b

Note: the previously mentioned patch had problems and was reverted, the proper upstream patch is 8fa9423bd873f2283be7b1e1e2fc80ffe8785155
Comment 8 tingting zheng 2014-06-06 03:07:57 EDT
I can reproduce this bug with:
virt-viewer-0.5.6-8.el6.x86_64

Tested pass with:
virt-viewer-0.6.0-5.el6.x86_64

Set the original resolution of the guest as 1280x768,when zoom out several times,it will not change.Also tried some other resolutions,when zoom out,the resolution will not change,so move the bug to VERIFIED.
Comment 9 errata-xmlrpc 2014-10-14 02:29:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1379.html

Note You need to log in before you can comment on or make changes to this bug.