Bug 100407 - RFE: Main menu icon not part of icon themes
Summary: RFE: Main menu icon not part of icon themes
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: gnome-panel (Show other bugs)
(Show other bugs)
Version: beta1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature, MoveUpstream, Triaged
Depends On: 117033 117035
Blocks: FC2Target
TreeView+ depends on / blocked
 
Reported: 2003-07-22 05:42 UTC by Nathan G. Grennan
Modified: 2007-04-18 16:55 UTC (History)
2 users (show)

Fixed In Version: 2.5.91-2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-03 15:17:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nathan G. Grennan 2003-07-22 05:42:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.11 (X11; Linux i686; U;) Gecko/20030720

Description of problem:
The gnome panel's main menu icon is not controlled by the icon theme. To change
it requires finding information on a gconf setting that doesn't exist by
default, and setting it. I think it should be part of of the icon themes. So I
can switch to the gnome icon theme and get a gnome foot. Then say switch back to
bluecurve and get the redhat icon.

Version-Release number of selected component (if applicable):
control-center-2.2.2-1

How reproducible:
Always

Steps to Reproduce:
1. Select Main menu
2. Selet Preferences
3. Select Theme
4. Select Details
5. Select the Icons tab
6. Select Gnome
7. Select Close
8. Select Close

Actual Results:  Main menu icon doesn't change while other icons do.

Expected Results:  Main menu icon to change along with other icons.

Additional info:

Comment 1 Havoc Pennington 2003-08-07 20:44:22 UTC
I think this may have changed in gnome-panel 2.4

Comment 2 Leonard den Ottolander 2004-02-27 00:02:33 UTC
This has *not* changed with 2.4.2-1.

I checked a couple of themes, all of which gave the following error:

Failed to load image icon-x-config.png
Details: file not found

Comment 3 Bart Martens 2004-02-27 13:25:40 UTC
No such error here, but I agree that the main menu icon doesn't change
while all others do, on fc1. So basically I agree with Leonard that
this problem still exists on fc1.


Comment 4 Bart Martens 2004-02-27 13:59:08 UTC
OK I see. In the spec file there is this modification with perl:

## replace foot menu with redhat-main-menu
perl -pi -e 's/gnome-main-menu/redhat-main-menu/g'
gnome-panel/panel-stock-icons.c
perl -pi -e 's/gnome-logo-icon-transparent/redhat-main-menu/g'
gnome-panel/panel-stock-icons.c

This makes the redhat icon be shown where normally the gnome foot
would be shown. So I guess Nathan made a wrong assumption in the bug
description. Right?

Maybe it's better to replace the perl modification by some real
redhat/fedora customization using the themes infrastructure. But I
guess that would be more work. :-)

So there's a choice, either change the scope of this bug, or close it
as notabug, or open a separate bug report.


Comment 5 Miloslav Trmac 2004-02-27 14:03:05 UTC
The main menu icon _is_ controlled by the theme, it just requires
panel restart.
After changing the theme, run (pkill gnome-panel) and the icon will
change.

This does not contradict the fact that the icon name has changed
(there is a symlink 
/usr/share/icons/gnome/48x48/apps/redhat-main-menu.png ->
/usr/share/pixmaps/gnome-logo-icon-transparent.png
).

Comment 6 Leonard den Ottolander 2004-02-27 14:08:42 UTC
The warning in comment 3 is only caused by the fact that I use that
icon for xterm in the panel. Please ignore.


Comment 7 Mark McLoughlin 2004-02-27 16:46:20 UTC
Okay, there are a number of things we need to do here:

  1) Rename redhat-main-menu in BlueCurve to gnome-main-menu

  2) Remove the redhat-main-menu symlink in /usr/share/icons/hicolor

  3) When both of those are done, remove the perl substitutions from
     gnome-panel and Require the versions of gnome-icon-theme and
     redhat-artwork with the fixes

Comment 8 Leonard den Ottolander 2004-03-02 16:03:31 UTC
Is this part of the new update?

Could you please put updates through testing before releasing into the
main channel?


Comment 9 Mark McLoughlin 2004-03-02 16:23:30 UTC
No, this fix isn't in the FC1 update. Hopefully it will be fixed
before FC2 test2.

As regards your other question - a) please stop asking random
questions about stuff that has nothing to do with the bug in question,
send me a mail if you like and b) not all updates need to go through a
period in testing - I was confident that both of these fixes were
trivial enough to not need serious testing.

Comment 10 Alexander Larsson 2004-03-02 20:32:53 UTC
1) is in redhat-artwork 0.93


Note You need to log in before you can comment on or make changes to this bug.