Bug 1004109 - Temporary CopyTrans options for version can overwrite CopyTrans options for project
Temporary CopyTrans options for version can overwrite CopyTrans options for p...
Status: CLOSED WORKSFORME
Product: Zanata
Classification: Community
Component: Component-CopyTrans (Show other bugs)
development
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Alex Eng
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 20:32 EDT by David Mason
Modified: 2014-05-28 21:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-28 21:21:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mason 2013-09-03 20:32:48 EDT
Description of problem:
CopyTrans options can be persisted at the level of the project, and can be temporarily set but not persisted when running CopyTrans for a version, however it is possible for the temporary settings for a single run to overwrite the persistent settings for a project.


Version-Release number of selected component (if applicable):
version 3.1-SNAPSHOT (20130904-0037)

How reproducible:
Easy, Always.



Steps to Reproduce:
1. Sign in as admin or maintainer of a project
2. Set Copy Trans Options for a project, and Save
3. Navigate to a version under the project
4. Click 'Copy Translations' and run with any settings. Wait for it to finish.
5. Click 'Copy Translations' again, change the settings, and click either 'Start' or 'Cancel'
6. Look at the project Copy Trans Options

Actual results:
Project Copy Trans Options have been changed to the settings in step 5.


Expected results:
Project Copy Trans Options do not change.

Additional info:
Comment 1 Alex Eng 2014-05-27 23:52:42 EDT
Cannot reproduce bug. Please retest this.
Comment 2 Ding-Yi Chen 2014-05-28 21:21:05 EDT
Tested with 
Zanata 3.4.2-SNAPSHOT (git-server-3.4.1-1-g722ff43) 
Zanata 3.5.0-SNAPSHOT (git-server-3.4.1-36-gd5f92ff)

The problem cannot be reproduced, perhaps it is a side-effect of UI redesign.

Note You need to log in before you can comment on or make changes to this bug.