Bug 100413 - mozilla ugly fonts after install
Summary: mozilla ugly fonts after install
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: mozilla (Show other bugs)
(Show other bugs)
Version: beta1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-22 08:06 UTC by Marco
Modified: 2007-04-18 16:55 UTC (History)
3 users (show)

Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 15:55:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marco 2003-07-22 08:06:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
After a standard install of Redhat 9 / Severn, Mozilla defaults to Serif as it
Proportional font. This is ugly. Sans serife as it's default would be much
nicer, I always change it right after the install. New users may think the fonts
in Linux are still ugly now.

Version-Release number of selected component (if applicable):
Beta 1


How reproducible:
Always

Steps to Reproduce:
1. install
2. see

    

Actual Results:  'ugly' default font

Expected Results:  Very nice sans serife font

Additional info:

Comment 1 Bruce A. Locke 2003-07-22 09:59:40 UTC
The serif font appears to have rendering bugs in mozilla 1.4 (as provided) with
underlined text (such as links, etc).  If these are not rendering bugs then
perhaps the default serif font should be changed to a different font?

Comment 2 Eugenia Loli-Queru 2003-07-25 20:49:16 UTC
Yup, it does that here too. Here is a screenshot where Mozilla is choosing the 
wrong font: http://img.osnews.com/img/4091/severn1.jpg
as you can see, instead of choosing an Arial or Helvetica Sans Serif font, it 
chooses a Serif font and makes it bold. Other sites like Slashdot and news.com 
also exhibit the problem.

I was able to fix the problem by going to the Prefs/Font panel of Mozilla and 
tell the Sans Serif drop down menu to choose sans serif fonts and not Serif 
ones.

But obviously, this should be corrected in your default Mozilla package as 
well. RHL9 did not have that problem, it first appeared in Severn it seems.

Comment 3 Milan Kerslager 2003-07-30 12:35:05 UTC
It seems that other applications have the same problem (at least the same
behavior you can see in OpenOffice and Epiphany).

Comment 4 Kyle R Maxwell 2003-08-01 21:56:43 UTC
As long as we're fixing Mozilla, what about Firebird?

Comment 5 Christopher Blizzard 2003-08-22 18:16:15 UTC
These defaults are provided via fontconfig for the most part.  Assuming that you
don't have something odd picked on the fonts preference panel.

Comment 6 Marco 2003-10-16 21:44:38 UTC
Is this being worked on for a default install? In Fedora TEST 3 it's still ugly
with a default install.

Comment 7 Bill Nottingham 2006-08-07 15:56:02 UTC
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still running
Red Hat Linux, you are strongly advised to upgrade to a current Fedora Core
release or Red Hat Enterprise Linux or comparable. Some information on which
option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do want to
make sure that no important bugs slip through the cracks. Please check if this
issue is still present in a current Fedora Core release. If so, please change
the product and version to match, and check the box indicating that the
requested information has been provided. Note that any bug still open against
Red Hat Linux by the end of 2006 will be closed as 'CANTFIX'. Thanks again for
your help.


Comment 8 Milan Kerslager 2006-08-10 15:41:20 UTC
The font situation seems to be OK on recent Fedora and RHEL computers. So I
recommend to close with CURRENT_RELEASE or so.


Note You need to log in before you can comment on or make changes to this bug.