Bug 1004135 - ibus: cannot enter ASCII text into gnome applications when using ssh
ibus: cannot enter ASCII text into gnome applications when using ssh
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
19
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 23:26 EDT by Harshula Jayasuriya
Modified: 2013-11-25 23:14 EST (History)
5 users (show)

See Also:
Fixed In Version: ibus-1.5.4-2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 01:43:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harshula Jayasuriya 2013-09-03 23:26:08 EDT
Description of problem:

When IBus is enabled, there are problems with inputting text via ssh to gnome applications such as epiphany/gedit.

Steps to Reproduce:

0) Enable IBus
1) Enable SSH server so that you can SSH to your system
2) ssh -Y or ssh -X into your system
3) Open epiphany or gedit
4) Enter text

Actual results:
* text does not appear in the application

Expected results:
* text appears in the application

Additional info:

(gedit:20828): IBUS-WARNING **: Events queue growing too big, will start to drop.
Comment 1 fujiwara 2013-09-06 00:19:41 EDT
ibus is based on dbus and it does not support client-server connection.
So you need to run ibus-daemon in the server side.

# ssh -Y server
server% ibus-daemon --xim &
server% env GTK_IM_MODULE=ibus gedit
Comment 2 Harshula Jayasuriya 2013-09-11 02:04:37 EDT
BTW, the problem is that English text is not appearing. And you can verify this by using your own desktop system, enabling ssh server and logging into your own account on the same system.
Comment 3 Jens Petersen 2013-09-11 02:10:56 EDT
This seems to be a regression -  when one tries to test this
with recent ibus one sees many warnings like:

(gedit:20828): IBUS-WARNING **: Events queue growing too big, will start to drop.

This happens at least with ibus-1.5.2-8.fc19.x86_64 and later,
but not with ibus-1.5.1-2.fc18.
Comment 4 fujiwara 2013-09-12 00:36:06 EDT
(In reply to Jens Petersen from comment #3)
> This seems to be a regression -  when one tries to test this
> with recent ibus one sees many warnings like:
> 
> (gedit:20828): IBUS-WARNING **: Events queue growing too big, will start to
> drop.
> 
> This happens at least with ibus-1.5.2-8.fc19.x86_64 and later,
> but not with ibus-1.5.1-2.fc18.

I cannot reproduce your problem.

Did you see any errors with strace gedit?
Comment 5 Jens Petersen 2013-09-13 04:23:22 EDT
It is pretty easy to reproduce:

1. boot F19-x86_64-DESK-20130806.iso (F19 respin)
2. setup ibus
3. ssh -X localhost gedit
4. try to input ascii directly (and can't)

The ibus warnings "Events queue growing too big, will start to drop."
suggest something is wrong.
Comment 6 Jens Petersen 2013-09-13 05:53:53 EDT
I can also reproduce on my own desktop running current F19.
ibus-1.5.2-7.fc19 also seems okay.

I forgot a couple of minor starts above:

2.1 su
2.2 systemctl start sshd
2.3 passwd liveuser
Comment 7 fujiwara 2013-09-18 03:51:08 EDT
OK, if ibus-daemon is running on another display, it can happen.
The following is the tentative patch:

--- ibus-1.5.3/client/gtk2/ibusimcontext.c.orig
+++ ibus-1.5.3/client/gtk2/ibusimcontext.c
@@ -740,7 +740,13 @@ ibus_im_context_filter_keypress (GtkIMCo
 
     IBusIMContext *ibusimcontext = IBUS_IM_CONTEXT (context);
 
-    if (!_daemon_is_running)
+    /* If ibus-daemon is running and run ssh -X localhost,
+     * _daemon_is_running == TRUE but ibus_get_address() == NULL
+     * so IBusBus is not connected and ibusimcontext->ibuscontext == NULL
+     * and ibusimcontext->events_queue could go beyond MAX_QUEUED_EVENTS
+     * because hostname and display number are different between
+     * ibus-daemon and clients. */
+    if (!_daemon_is_running || ibus_get_address () == NULL)
         return gtk_im_context_filter_keypress (ibusimcontext->slave, event);
 
     /* If context does not have focus, ibus will process key event in
Comment 9 Fedora Update System 2013-09-23 23:04:08 EDT
ibus-1.5.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-17327/ibus-1.5.4-1.fc20
Comment 10 Fedora Update System 2013-09-23 23:05:26 EDT
ibus-1.5.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-17357/ibus-1.5.4-1.fc19
Comment 11 Fedora Update System 2013-09-23 23:06:14 EDT
ibus-1.5.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2013-17371/ibus-1.5.4-1.fc18
Comment 12 Fedora Update System 2013-09-28 21:40:11 EDT
ibus-1.5.4-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2013-09-29 20:43:12 EDT
ibus-1.5.4-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2013-10-04 04:58:03 EDT
ibus-1.5.4-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-1.5.4-2.fc19
Comment 15 Fedora Update System 2013-10-04 04:58:36 EDT
ibus-1.5.4-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-1.5.4-2.fc18
Comment 16 Fedora Update System 2013-10-04 04:59:15 EDT
ibus-1.5.4-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ibus-1.5.4-2.fc20
Comment 17 Fedora Update System 2013-10-04 21:41:22 EDT
Package ibus-1.5.4-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.5.4-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18298/ibus-1.5.4-2.fc20
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2013-11-10 01:43:16 EST
ibus-1.5.4-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2013-11-25 23:06:04 EST
ibus-1.5.4-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2013-11-25 23:14:19 EST
ibus-1.5.4-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.