Bug 1004170 - Condor service cannot start after installation and machine restart
Condor service cannot start after installation and machine restart
Status: CLOSED WONTFIX
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor (Show other bugs)
Development
Unspecified Windows
unspecified Severity high
: ---
: ---
Assigned To: Erik Erlandson
Petra Svobodová
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 02:55 EDT by Petra Svobodová
Modified: 2016-05-26 15:33 EDT (History)
6 users (show)

See Also:
Fixed In Version: condor-win-7.8.9-0.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-26 15:33:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petra Svobodová 2013-09-04 02:55:26 EDT
Description of problem:
After installation and restart the machine the condor service cannot start (it is not started automatically and it is not possible to start it manually). The error message appears after attempting to start the condor service:

"Windows could not start the condor service on Local Computer.

Error 1053: The service did not respond to the start or control request in a timely fashion."

There are two error messages in the Windows logs:
"A timeout was reached (30000 milliseconds) while waiting for the condor service to connect."
"The condor service failed to start due to the following error: 
The service did not respond to the start or control request in a timely fashion."

This issue was appeared on Windows Server2008-x86 and Windows Server 2008-x64 only, not on Windows Server2008 R2 or another Windows platform.

Version-Release number of selected component (if applicable):
condor-7.8.9-0.5.msi

How reproducible:
100%

Steps to Reproduce:
1. Install the msi package.
2. Restart the machine.
3. Wait several minutes and look at if the condor service is running; if it is not, try to run it manually.

Actual results:
The condor service cannot run and the error message is displayed.

Expected results:
The condor service should be running and if it is not currently running, it should be possible to run it manually.
Comment 1 Petra Svobodová 2013-09-05 03:35:38 EDT
This issue did not occur on condor-win-7.8.9-0.2 (condor-win-7.8.9-0.4 was added into brew the same day as the package condor-win-7.8.9-0.5, so it was not tested).

Installed condor-win-7.8.9-0.5 cannot start only on Windows Server2008-x86 and x64; it runs normally on other Windows platforms.

If I can help with anything, write me, please.
Comment 7 Petra Svobodová 2013-09-16 07:21:24 EDT
The condor service can be installed and run on all supported Windows platforms.

Verified on condor-win-7.8.9-0.8 on platforms:
- Windows7-x86 and x64
- WindowsXP-x86
- Windows Server2003-x86 and x64
- Windows Server2008-x86, x64 and R2

--> VERIFIED
Comment 8 Anne-Louise Tangring 2016-05-26 15:33:29 EDT
MRG-Grid is in maintenance and only customer escalations will be considered. This issue can be reopened if a customer escalation associated with it occurs.

Note You need to log in before you can comment on or make changes to this bug.