Bug 1004198 - cups-lpd runs as init_t when cups-lpd.socket is active
cups-lpd runs as init_t when cups-lpd.socket is active
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks: 1004161
  Show dependency treegraph
 
Reported: 2013-09-04 03:59 EDT by Milos Malik
Modified: 2014-06-17 22:25 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-77.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:47:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2013-09-04 03:59:17 EDT
Description of problem:

Version-Release number of selected component (if applicable):
selinux-policy-3.12.1-73.el7.noarch
selinux-policy-devel-3.12.1-73.el7.noarch
selinux-policy-doc-3.12.1-73.el7.noarch
selinux-policy-minimum-3.12.1-73.el7.noarch
selinux-policy-mls-3.12.1-73.el7.noarch
selinux-policy-targeted-3.12.1-73.el7.noarch
cups-lpd-1.6.3-6.el7.x86_64

How reproducible:
always

Steps to Reproduce:
# systemctl enable cups-lpd.socket
ln -s '/usr/lib/systemd/system/cups-lpd.socket' '/etc/systemd/system/sockets.target.wants/cups-lpd.socket'
# systemctl start cups-lpd.socket
# systemctl status cups-lpd.socket
cups-lpd.socket - CUPS-LPD Server Socket
   Loaded: loaded (/usr/lib/systemd/system/cups-lpd.socket; enabled)
   Active: active (listening) since Wed 2013-09-04 09:53:10 CEST; 4s ago
   Listen: [::]:515 (Stream)
 Accepted: 0; Connected: 0

Sep 04 09:53:10 rhel70 systemd[1]: Listening on CUPS-LPD Server Socket.
# nc -v 127.0.0.1 515
Ncat: Version 6.40 ( http://nmap.org/ncat )
Ncat: Connected to 127.0.0.1:515.
^Z
[1]+  Stopped                 nc -v 127.0.0.1 515
# nc -v 127.0.0.1 515
Ncat: Version 6.40 ( http://nmap.org/ncat )
Ncat: Connected to 127.0.0.1:515.
^Z
[2]+  Stopped                 nc -v 127.0.0.1 515
# ps -efZ | grep cups
system_u:system_r:init_t:s0     lp        1611     1  0 09:55 ?        00:00:00 /usr/lib/cups/daemon/cups-lpd
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 root 1613 24725  0 09:55 pts/0 00:00:00 grep --color=auto cups
# fg
nc -v 127.0.0.1 515
^C
# 

Actual results:
 * cups-lpd process is not labelled correctly

Expected results:
 * cups-lpd process is labelled correctly
Comment 1 Miroslav Grepl 2013-09-04 04:42:48 EDT
Milos,
are you going to create new bugs for each services from the original bug?
Comment 3 Daniel Walsh 2013-09-05 09:34:35 EDT
617a0acf0e6d464fce9b485799f41e29084dfb87 fixes this in git.
Comment 5 Ludek Smid 2014-06-13 06:47:50 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.