Bug 1004207 - [whql][netkvm]BSoD occurs(0xd1) when running DP WLK - Hot-Add - Device Test - Verify driver support for Hot-Add CPU job on win2012R2(Preview) on HCK 2.1.9431
[whql][netkvm]BSoD occurs(0xd1) when running DP WLK - Hot-Add - Device Test -...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 04:11 EDT by Min Deng
Modified: 2014-07-11 02:17 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 07:42:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Min Deng 2013-09-04 04:11:00 EDT
Description of problem:
The job named DP WLK - Hot-Add - Device Test - Verify driver support for Hot-Add CPU failed on win2012R2 OS.

Version-Release number of selected component (if applicable):
build67
kernel-2.6.32-414.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.397.el6.x86_64
How reproducible:
5 times

Steps to Reproduce:
1.boot up guest 
  /usr/libexec/qemu-kvm -m 4G -smp 4,cores=4 -cpu cpu64-rhel6,+x2apic -usb -device usb-tablet -drive file=win2012-R2-nic1.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:33:c3:02:21:21,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet2,mac=00:22:46:c3:33:07,bus=pci.0,addr=0x6 -uuid d2738299-9f2f-41a2-863b-e3e2d1895b43 -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win8-32-nic1,server,nowait -mon chardev=111a,mode=readline -vnc :1 -vga cirrus -rtc base=localtime,clock=host,driftfix=slew -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio
root     25656 15.9 11.0 2459592 833184 pts/6  Sl+  15:28   6:01 /usr/libexec/qemu-kvm -m 2G -smp 1,cores=1 -cpu cpu64-rhel6,+x2apic -usb -device usb-tablet -drive file=win2012-R2-nic2.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:33:53:12:31:21,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet2,mac=00:23:44:c3:33:07,bus=pci.0,addr=0x6 -uuid 95e9461c-fd7c-4b3b-a5f9-1bd9b09c1856 -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win8-32-nic2,server,nowait -mon chardev=111a,mode=readline -vnc :2 -vga cirrus -name win8-32-67-2 -rtc base=localtime,clock=host,driftfix=slew -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio
2.Submit the job to HCK 2.1

Actual results:
The job always failed due to "Add CPUs" subjob failed. 

Expected results:
The job can pass.

Additional info:
I will upload hck to the bug after a while
Comment 2 Min Deng 2013-09-04 04:15:09 EDT
Created attachment 793528 [details]
hck-log
Comment 3 Min Deng 2013-09-04 05:33:51 EDT
It got an BSOD issue.
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)
An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arguments:
Arg1: fffff800006eb260, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000008, value 0 = read operation, 1 = write operation
Arg4: fffff800006eb260, address which referenced memory

Debugging Details:
------------------


READ_ADDRESS: fffff8015a53c340: Unable to get special pool info
fffff8015a53c340: Unable to get special pool info
 fffff800006eb260 

CURRENT_IRQL:  2

FAULTING_IP: 
NDIS!ndisCreateThread+0
fffff800`006eb260 488bc4          mov     rax,rsp

DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT

BUGCHECK_STR:  AV

PROCESS_NAME:  System

TRAP_FRAME:  ffffd00020987ad0 -- (.trap 0xffffd00020987ad0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=ffffcf800009efe0 rbx=0000000000000000 rcx=fffff80000654dd0
rdx=0000000000000001 rsi=0000000000000000 rdi=0000000000000000
rip=fffff800006eb260 rsp=ffffd00020987c68 rbp=0000000000000000
 r8=0000000000000008  r9=ffffcf800009efe8 r10=ffffd00020989000
r11=ffffd00020987ce0 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl nz na pe nc
NDIS!ndisCreateThread:
fffff800`006eb260 488bc4          mov     rax,rsp
Resetting default scope

LOCK_ADDRESS:  fffff8015a558fe0 -- (!locks fffff8015a558fe0)

Resource @ nt!PiEngineLock (0xfffff8015a558fe0)    Exclusively owned
    Contention Count = 6
     Threads: ffffe000011958c0-01<*> 
1 total locks, 1 locks currently held

PNP_TRIAGE: 
	Lock address  : 0xfffff8015a558fe0
	Thread Count  : 1
	Thread address: 0xffffe000011958c0
	Thread wait   : 0x7818

LAST_CONTROL_TRANSFER:  from fffff8015a3e09e9 to fffff8015a3d4da0

FAILED_INSTRUCTION_ADDRESS: 
NDIS!ndisCreateThread+0
fffff800`006eb260 488bc4          mov     rax,rsp

STACK_TEXT:  
ffffd000`20987988 fffff801`5a3e09e9 : 00000000`0000000a fffff800`006eb260 00000000`00000002 00000000`00000008 : nt!KeBugCheckEx
ffffd000`20987990 fffff801`5a3df23a : 00000000`00000008 00000000`00000080 ffffd000`20987c00 ffffd000`20987ad0 : nt!KiBugCheckDispatch+0x69
ffffd000`20987ad0 fffff800`006eb260 : fffff800`0068d5b8 00000000`00000080 00000000`00000000 00000000`00000001 : nt!KiPageFault+0x23a
ffffd000`20987c68 fffff800`0068d5b8 : 00000000`00000080 00000000`00000000 00000000`00000001 00000000`00010297 : NDIS!ndisCreateThread
ffffd000`20987c70 fffff800`007057a4 : ffffd000`00000300 ffffe000`00010000 ffffd000`20987d58 ffffe000`0013fc30 : NDIS!ndisPeriodicReceivesAddCpu+0x94
ffffd000`20987cb0 fffff801`5a2bc7c7 : ffffe000`001458e8 fffff801`5a77a20b ffffd000`20987e90 fffff801`5a36571f : NDIS!ndisCpuHotAddHandler+0x6c
ffffd000`20987ce0 fffff801`5a461751 : 00000000`00000000 ffffd000`20987d80 fffff801`5a529040 ffffd000`236c7180 : nt!ExNotifyWithProcessing+0xdb
ffffd000`20987d30 fffff801`5a876a9c : 00000000`00000000 ffffd000`20987e90 fffff801`5a529040 ffffd000`236c7180 : nt!KiDynamicProcessorAddNotification+0x51
ffffd000`20987d90 fffff801`5a877414 : 00000000`00000000 fffff801`5a87734c ffffcf80`049b4e50 00000000`00010246 : nt!KiStartDynamicProcessor+0x3a0
ffffd000`20988570 fffff800`01fddac1 : ffffcf80`049b4e50 ffffd000`20988619 00000000`00000002 ffffe000`02676800 : nt!KeStartDynamicProcessor+0xc8
ffffd000`209885b0 fffff800`01fdd558 : ffffcf80`049b4e50 fffff800`01fde960 ffffcf80`049b4e50 00000000`00000001 : pnpcpu!ToasterStartDevice+0x10d
ffffd000`20988680 fffff801`5a8f38c1 : ffffcf80`049b4e50 ffffe000`026766b0 00000000`00000002 ffffe000`00c054a0 : pnpcpu!ToasterDispatchPnp+0x288
ffffd000`209886c0 fffff801`5a62bd16 : ffffcf80`049b4e50 ffffe000`02872090 ffffe000`026766b0 ffffe000`00c054a0 : nt!IovCallDriver+0x3cd
ffffd000`20988710 fffff801`5a36bac6 : ffffe000`024cf5e0 ffffd000`209887b9 00000000`00000000 fffff801`5a639ec0 : nt!PnpAsynchronousCall+0x102
ffffd000`20988750 fffff801`5a715d97 : ffffe000`027e68a0 ffffe000`027e68a0 ffffe000`02872090 00000000`00000000 : nt!PnpStartDevice+0xc2
ffffd000`20988820 fffff801`5a715c13 : ffffe000`027e68a0 ffffe000`027e68a0 00000000`00000000 ffffe000`027e68a0 : nt!PnpStartDeviceNode+0x147
ffffd000`209888f0 fffff801`5a6316a2 : ffffe000`027e68a0 00000000`00000001 00000000`00000001 ffffe000`00000001 : nt!PipProcessStartPhase1+0x53
ffffd000`20988930 fffff801`5a71c26f : ffffe000`027e68a0 00000000`00000000 00000000`00000000 ffffe000`02542140 : nt!PipProcessDevNodeTree+0x3ea
ffffd000`20988bb0 fffff801`5a36c5af : 00000001`00000003 00000000`00000000 fffff801`5a557a80 00000000`00000001 : nt!PiRestartDevice+0xaf
ffffd000`20988c00 fffff801`5a2c4efd : ffffe000`011958c0 00000000`00000000 fffff801`5a557a80 ffffcf80`04176fb0 : nt!PnpDeviceActionWorker+0x3c7
ffffd000`20988cb0 fffff801`5a365968 : 00000000`00000000 ffffe000`011958c0 00000000`00000080 ffffe000`011958c0 : nt!ExpWorkerThread+0x129
ffffd000`20988d40 fffff801`5a3db3c6 : fffff801`5a578180 ffffe000`011958c0 ffffe000`001448c0 00000000`00000000 : nt!PspSystemThreadStartup+0x58
ffffd000`20988da0 00000000`00000000 : ffffd000`20989000 ffffd000`20983000 00000000`00000000 00000000`00000000 : nt!KiStartSystemThread+0x16


STACK_COMMAND:  kb

FOLLOWUP_IP: 
pnpcpu!ToasterStartDevice+10d
fffff800`01fddac1 eb3a            jmp     pnpcpu!ToasterStartDevice+0x149 (fffff800`01fddafd)

SYMBOL_STACK_INDEX:  a

SYMBOL_NAME:  pnpcpu!ToasterStartDevice+10d

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: pnpcpu

IMAGE_NAME:  pnpcpu.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  51bd4d15

BUCKET_ID_FUNC_OFFSET:  10d

FAILURE_BUCKET_ID:  AV_VRF_CODE_AV_BAD_IP_pnpcpu!ToasterStartDevice

BUCKET_ID:  AV_VRF_CODE_AV_BAD_IP_pnpcpu!ToasterStartDevice

Followup: MachineOwner
---------
Comment 5 RHEL Product and Program Management 2013-10-13 22:23:54 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 lijin 2013-10-25 01:29:57 EDT
win2012R2 guest bsod when running this job on HCK2.1 with each of the following virtio-win drivers:
netkvm:virtio-win-prwhql-72;
serial:virtio-win-prwhql-70:
balloon::virtio-win-prwhql-70;
scsi:virtio-win-prwhql-71:
blk:virtio-win-prwhql-71

test package info:
qemu-kvm-rhev-0.12.1.2-2.405.el6.x86_64
kernel-2.6.32-420.el6.x86_64
seabios-0.6.1.2-28.el6.x86_64
Comment 7 Yan Vugenfirer 2013-11-06 03:26:54 EST
Please retest on RTM version of Windows 2012R2 with latest HCK.
Comment 8 Yan Vugenfirer 2013-11-21 07:42:28 EST
Closing for now. Cannot reproduce with latest HCK kit and on Windows Server 2012R2 RTM.

Note You need to log in before you can comment on or make changes to this bug.