Bug 1004212 - [RHEVM][webadmin] Version number is not shown when clicking 'About'
[RHEVM][webadmin] Version number is not shown when clicking 'About'
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity high
: ---
: 3.3.0
Assigned To: Alexander Wels
Pavel Novotny
ux
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 04:21 EDT by tgeft
Modified: 2013-09-29 22:49 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-24 09:54:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tgeft 2013-09-04 04:21:20 EDT
Description of problem:
When clicking 'About' on the top menu bar the version number is not shown.


Version-Release number of selected component (if applicable):
3.3.0-0.19.master.el6ev 

How reproducible:
100%

Steps to Reproduce:
1. Click on 'About' on the top menu bar

Actual results:
only "oVirt Engine Version:" is shown

Expected results:
The version number shouldbe shown as well

Additional info:
Comment 1 Pavel Novotny 2013-09-04 09:32:35 EDT
I will elaborate more on this issue. This bug seems to be related to the branding support (and breaking it).
The `About` dialog is not the only place where the text is comletely missing or is not replaced by user-defined value from another branding profile (theme).

Assuming that the branding support works the way, that all messages (and also  CSS, images, etc.) defined in the base oVirt theme [1] should be overridden by the RHEV theme [2].

[1] /etc/ovirt-engine/branding/00-ovirt.brand/messages.properties
[2] /etc/ovirt-engine/branding/50-rhev-1.brand/messages.properties


Spots with missing/wrong labels:
--~--
About dialog (Webadmin & User Portal)
- the text "oVirt Engine Version:" is hard-coded, cannot be set via themes (obrand.common.version_about, obrand.common.copy_right_notice)

Login page (Webadmin & User Portal)
- dialog header label - text not overridden by RHEV theme, oVirt value used; (obrand.common.login_header_label)

User Portal 
- main header label "oVirt Engine" - text not defined in RHEV theme, oVirt value used; (obrand.userportal.main_header_label)

Webadmin
- main header label - text not defined in RHEV theme, empty value from oVirt theme used; (obrand.webadmin.main_header_label)
--~--

Also worth to mention that other branding resources (CSS, images) are loaded and displayed correctly.
Comment 2 Pavel Novotny 2013-09-04 09:34:33 EDT
Regression against rhevm-3.3.0-0.18.master.el6ev (IS12).
Comment 3 Alexander Wels 2013-09-24 09:54:32 EDT
I spoke with Pavel, he says he can no longer produce it in is15, feel free to re-open if it comes back. I think we had a bad build earlier that might have caused this.

Note You need to log in before you can comment on or make changes to this bug.