Bug 1004247 - VirtError message appears in the terminal which bring up virt-manager when migrate the guest
VirtError message appears in the terminal which bring up virt-manager when mi...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-who (Show other bugs)
5.10
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Radek Novacek
John Sefler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 05:39 EDT by Liushihui
Modified: 2016-11-30 19:31 EST (History)
4 users (show)

See Also:
Fixed In Version: virt-who-0.9-1.el5
Doc Type: Bug Fix
Doc Text:
no docs needed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-15 20:29:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liushihui 2013-09-04 05:39:15 EDT
Description of problem:
Although migrate successfully, But the terminal which brought up virt-manager will appear VirtError message after migrate guest on both source and destination hosts.

Version-Release number of selected component (if applicable):
subscription-manager-1.8.21-1.el5
python-rhsm-1.8.17-1.el5
virt-who-0.7-9.el5
katello-headpin-1.4.3-11.el6sam_splice.noarch
candlepin-0.8.24-1.el6sam.noarch

How reproducible:
50%

Steps to Reproduce:
Rrecondition:
Prepare a pair of host(host1 and host2), guest is running on the host1, run the following cmd in the host3 , Register host1 , host2 and guest1 to stage candlepin server successfully.

virt-who run in the libvirtd mode.
1 In the Terminal1, ssh login to the host1, bring up the virt-manager
# ssh -X root@[host1's ip]
# virt-manager
2 In the Terminal2, ssh login to the host2, bring up the virt-manager
# ssh -X root@[host2's ip]
# virt-manager
3 Make sure the virt-who and libvirtd is running in the host1 and host2
# service virt-who status
# service libvirtd status
4 In the Terminal1, Live Migrate guest1 from host1 to host2 
# virsh migrate --live [guestname] qemu+ssh://[host2's ip]/system

5 Check the pop up message in the terminal1(host1):
[root@hp-z220-08 images]# virsh migrate --live Rhel5.10snapshot5A qemu+ssh://10.66.100.112/system
root@10.66.100.112's password: 
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 1941, in dispatchDomainEventCallbacks
    cb(self,dom,event,detail,opaque)
  File "/usr/share/virt-who/virt.py", line 74, in changed
    l = self.listDomains()
  File "/usr/share/virt-who/virt.py", line 64, in listDomains
    raise VirtError(str(e))
virt.VirtError: invalid connection pointer in virConnectListDomains
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 1941, in dispatchDomainEventCallbacks
    cb(self,dom,event,detail,opaque)
  File "/usr/share/virt-who/virt.py", line 74, in changed
    l = self.listDomains()
  File "/usr/share/virt-who/virt.py", line 64, in listDomains
    raise VirtError(str(e))
virt.VirtError: invalid connection pointer in virConnectListDomains

6 Check the pop up message in the terminal2(host2)
[root@hp-z220-07 libvirt-test-API]# Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 1941, in dispatchDomainEventCallbacks
    cb(self,dom,event,detail,opaque)
  File "/usr/share/virt-who/virt.py", line 74, in changed
    l = self.listDomains()
  File "/usr/share/virt-who/virt.py", line 64, in listDomains
    raise VirtError(str(e))
virt.VirtError: invalid connection pointer in virConnectListDomains
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 1941, in dispatchDomainEventCallbacks
    cb(self,dom,event,detail,opaque)
  File "/usr/share/virt-who/virt.py", line 74, in changed
    l = self.listDomains()
  File "/usr/share/virt-who/virt.py", line 64, in listDomains
    raise VirtError(str(e))
virt.VirtError: invalid connection pointer in virConnectListDomains
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 1941, in dispatchDomainEventCallbacks
    cb(self,dom,event,detail,opaque)
  File "/usr/share/virt-who/virt.py", line 74, in changed
    l = self.listDomains()
  File "/usr/share/virt-who/virt.py", line 64, in listDomains
    raise VirtError(str(e))
virt.VirtError: invalid connection pointer in virConnectListDomains
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 1941, in dispatchDomainEventCallbacks
    cb(self,dom,event,detail,opaque)
  File "/usr/share/virt-who/virt.py", line 74, in changed
    l = self.listDomains()
  File "/usr/share/virt-who/virt.py", line 64, in listDomains
    raise VirtError(str(e))
virt.VirtError: invalid connection pointer in virConnectListDomains

Actual results:
see the error message after step5 and step6

Expected results:
It shouldn't appear error message on the terminal.


Additional info:
Comment 1 RHEL Product and Program Management 2014-01-29 05:34:41 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Radek Novacek 2014-03-24 09:15:49 EDT
Shi Hui Liu from QA team reports that this bug is no longer reproducible with virt-who-0.9-1.el5, so I suppose that the rebase fixes it.
Comment 4 Liushihui 2014-05-04 23:23:08 EDT
Verified on virt-who-0.9-1.el5
Comment 6 errata-xmlrpc 2014-09-15 20:29:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1206.html

Note You need to log in before you can comment on or make changes to this bug.