Bug 1004278 - cannot recognize xhci usb storage(port reset failed) after re-enable device
cannot recognize xhci usb storage(port reset failed) after re-enable device
Status: CLOSED DUPLICATE of bug 949514
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 06:26 EDT by Xu Han
Modified: 2013-10-30 04:08 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-30 04:08:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
device manager screenshot (108.30 KB, image/png)
2013-09-04 06:30 EDT, Xu Han
no flags Details

  None (edit)
Description Xu Han 2013-09-04 06:26:46 EDT
Description of problem:
cannot recognize xhci usb storage(port reset failed) after re-enable device in windows 2012 guest

Version-Release number of selected component (if applicable):
qemu: qemu-kvm-1.5.3-2.el7.x86_64
kernel: 3.10.0-15.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.boot guest
#/usr/libexec/qemu-kvm ... \
-device nec-usb-xhci,id=xhci,addr=0x04 \
-device usb-storage,drive=drive-usb-0-0,id=usb-0-0,removable=on,bus=xhci.0 \
-drive file=/mnt/add-disk.qcow2,if=none,id=drive-usb-0-0,media=disk,format=qcow2,cache=none,aio=native

2.disable usb storage from device manager

3.enable usb storage from device manager

Actual results:
cannot recognize usb storage device(attached screenshot)

Expected results:
can recognize usb storage device with no error

Additional info:
Comment 1 Xu Han 2013-09-04 06:30:27 EDT
Created attachment 793594 [details]
device manager screenshot
Comment 3 Gerd Hoffmann 2013-09-05 01:58:14 EDT
Probably a duplicate of bug 949514.
Comment 4 Xu Han 2013-09-05 02:33:21 EDT
(In reply to Gerd Hoffmann from comment #3)
> Probably a duplicate of bug 949514.

Hi Gerd,

at first, guest could recognize this usb storage, but failed after re-enable. So I think it may not be same as bug 949514.
Comment 5 Gerd Hoffmann 2013-10-29 09:47:33 EDT
Fix for bug 949514 is in qemu-kvm-1.5.3-7.el7 now, can you retest please?
Comment 6 Xu Han 2013-10-29 21:48:09 EDT
Retested on windows 2012-r2 guest with qemu-kvm-rhev-1.5.3-10.el7.x86_64, and not hit this issue any more.
According to above test result, please close this bug as duplicate of bug 949514.
Comment 7 Gerd Hoffmann 2013-10-30 04:08:09 EDT

*** This bug has been marked as a duplicate of bug 949514 ***

Note You need to log in before you can comment on or make changes to this bug.