Bug 1004303 - When updating fedora 19 with yum update, conflict on libkdchart.so.11 with calligra and kmymoney
When updating fedora 19 with yum update, conflict on libkdchart.so.11 with ca...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: calligra (Show other bugs)
19
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 07:21 EDT by BeGe
Modified: 2013-09-11 21:55 EDT (History)
3 users (show)

See Also:
Fixed In Version: kmymoney-4.6.3-12.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 21:55:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 324485 None None None Never

  None (edit)
Description BeGe 2013-09-04 07:21:52 EDT
When updating fedora 19 with yum update i got the following messages:
---> Package calligra-kdchart.i686 0:2.6.4-1.fc19 will be updated
--> Processing Dependency: libkdchart.so.11 for package: kmymoney-4.6.3-6.fc19.i686
---> Package calligra-kdchart.i686 0:2.7.2-1.fc19 will be an update
with probably a packaging discrepency between calligra and kmymoney

Reproducible: Always

Steps to Reproduce:
1.yum update (on fedora 19)
2.
3.
Actual Results:  
So if i use yum update --skip-broken, a couple of calligra rpms cannot be updated
Comment 1 BeGe 2013-09-04 07:25:08 EDT
I have got this comment from Alvaro Soliverez on https://bugs.kde.org/show_bug.cgi?id=324485

Yes, this is a downstream packaging issue. The version of kdchart used by KMyMoney cannot be shared with Calligra.
This situation (Calligra and KMyMoney both use KDChart but cannot share it) has been this way since the days of KOffice and KDE3. Something changed in the latest packaging.
Comment 2 Rex Dieter 2013-09-04 07:56:34 EDT
kmymoney added to calligra update recently, please try again:

https://admin.fedoraproject.org/updates/FEDORA-2013-15420
Comment 3 Fedora Update System 2013-09-04 07:57:18 EDT
kmymoney-4.6.3-12.fc19, calligra-l10n-2.7.2-1.fc19, calligra-2.7.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-15420/kmymoney-4.6.3-12.fc19,calligra-l10n-2.7.2-1.fc19,calligra-2.7.2-1.fc19
Comment 4 BeGe 2013-09-04 08:51:33 EDT
Thank you i will check these versions.

Kind regards.
Comment 5 Fedora Update System 2013-09-11 21:55:20 EDT
kmymoney-4.6.3-12.fc19, calligra-l10n-2.7.2-1.fc19, calligra-2.7.2-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.