Bug 1004309 - Different "Affected systems" in errata list after upgrade from satellite 5.4.1 to 5.6
Different "Affected systems" in errata list after upgrade from satellite 5.4....
Status: CLOSED DUPLICATE of bug 999453
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
560
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Milan Zázrivec
Red Hat Satellite QA List
: Regression
Depends On:
Blocks: sat560-blockers
  Show dependency treegraph
 
Reported: 2013-09-04 07:29 EDT by Pavel Studeník
Modified: 2013-09-05 08:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 08:55:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Studeník 2013-09-04 07:29:51 EDT
Description of problem:
I upgraded satellite from 5.4.1 to 5.6 with customer's data (external
oracle). When I compared data, I got different result in "affected systems"
columns in errata-list by spacewalk-report. I got same result in webUI (Errata -> detail of errata -> affected systems)

Version-Release number of selected component (if applicable):
spacewalk-java-2.0.2-29.el6sat.noarch
Satellite-5.6.0-RHEL6-re20130830.0-x86_64.iso

How reproducible:
always with customer's database

Steps to Reproduce:
1. spacewalk-report errata-list > spacewalk-report-POST/errata-list.csv
2.  - upgrade sattelite -
3. spacewalk-report errata-list > spacewalk-report-POST/errata-list.csv
4. diff spacewalk-report-POST/errata-list.csv spacewalk-report-PRE/errata-list.csv
2627c2627
< RHEA-2012:0356,Product Enhancement Advisory,,tzdata enhancement update,7
---
> RHEA-2012:0356,Product Enhancement Advisory,,tzdata enhancement update,11
2643c2643
< RHEA-2012:1299,Product Enhancement Advisory,,Red Hat Network Tools 5.5.0 General Availability,7
---
> RHEA-2012:1299,Product Enhancement Advisory,,Red Hat Network Tools 5.5.0 General Availability,3


Actual results:
After upgrade I got different list of "affected system" - webUI or spacewalk-report

Expected results:
Same result after upgrade
Comment 1 Stephen Herr 2013-09-05 08:55:14 EDT
This is a result of the first (wrong) attempt at a fix for bug 999453.

I am going to close this bug as a duplicate of bug 999453 so that all the related discussion can happen in one place.

*** This bug has been marked as a duplicate of bug 999453 ***

Note You need to log in before you can comment on or make changes to this bug.