Bug 100431 - DK_MAX_MAJOR 99 is not enough for cciss
DK_MAX_MAJOR 99 is not enough for cciss
Status: CLOSED DUPLICATE of bug 123136
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-22 07:22 EDT by masanari iida
Modified: 2007-11-30 17:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description masanari iida 2003-07-22 07:22:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

Description of problem:
sar -b output of disks under cciss driver are always all zero.
This symptom was caused by /usr/src/linux-2.4/include/linux/kernel_stat.h

#define DK_MAX_MAJOR 99

This value should be changed to 111 (for max /dev/cciss/c7d0).



Version-Release number of selected component (if applicable):
kernel 2.4.9-e.25

How reproducible:
Always

Steps to Reproduce:
1. Install RHAS 2.1 on HP Proliant with cciss driver.
2. Install sysstat
3. sar -b

    

Actual Results:  All disk I/O are zero.


Expected Results:  All disk I/O should be record.

Additional info:

This problem are reported other RedHat linux kernel
such as RH7.1, RH8.0.
Comment 2 Neil Horman 2004-08-25 16:25:32 EDT

*** This bug has been marked as a duplicate of 123136 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:57:39 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.