Bug 1004310 - tycho: Incorrect usage of %add_maven_depmap
tycho: Incorrect usage of %add_maven_depmap
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: tycho (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On: 1007203
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 07:33 EDT by Mikolaj Izdebski
Modified: 2014-01-06 18:13 EST (History)
4 users (show)

See Also:
Fixed In Version: 0.19.0-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-06 18:13:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2013-09-04 07:33:10 EDT
Description of problem:
Tycho calls %add_maven_depmap with second argument az ZIP file.  Currently %add_maven_depmap only supports installing JAR and POM files [1].  Behavior is unspecified if ZIP file is passed.  Currently it (sort of) works but Tycho is going to break with future versions of XMvn and Java Packages Tools if this bug is not fixed.

If you want Tycho to keep working after update to XMvn 1.0.0 and Java Packages Tools 3.0.0 then you need to change depmaps for all non-JAR and non-POM artifact and add artifact extensions, for example:

<dependency>
  <maven>
    <groupId>org.sonatype.tycho</groupId>
    <artifactId>tycho-bundles-external</artifactId>
    <extension>zip</extension>
    <version>0.18.1</version>
  </maven>
  <jpp>
    <groupId>JPP/tycho</groupId>
    <artifactId>tycho-bundles-external</artifactId>
    <extension>zip</extension>
    <version>0.18.1</version>
  </jpp>
</dependency>


Version-Release number of selected component (if applicable):
0.18.1-4

Additional info:
[1] http://fedoraproject.org/wiki/Packaging:Java#add_maven_depmap_macro
Comment 1 Mikolaj Izdebski 2013-09-04 07:40:33 EDT
(In reply to Mikolaj Izdebski from comment #0)
> If you want Tycho to keep working after update to XMvn 1.0.0 and Java
> Packages Tools 3.0.0 then you need to change depmaps for all non-JAR and
> non-POM artifact and add artifact extensions, for example:

Actually, that's not enough -- XMvn won't resolve ZIP from %_javadir as this directory is supposed to only contain JAR files.
Comment 2 Roland Grunberg 2013-09-04 17:03:56 EDT
So just to confirm, this would require installing the zip file to some location that isn't in %{_javadir} (I guess %{_datadir} could work), and replacing the %add_maven_depmap call with manually installing depmaps similar to the one above into %{_mavendepmapfragdir}.
Comment 3 Fedora Update System 2013-10-01 14:48:55 EDT
tycho-0.18.1-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/tycho-0.18.1-5.fc20
Comment 4 Fedora Update System 2013-10-02 02:46:15 EDT
Package tycho-0.18.1-5.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tycho-0.18.1-5.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18112/tycho-0.18.1-5.fc20
then log in and leave karma (feedback).
Comment 5 Mikolaj Izdebski 2013-10-02 03:33:52 EDT
This is still unresolved. I added a temporary workaround for the issue, but a proper fix is still to be implemented. Because of that I would like to keep this issue open until a real solution is commited.
Comment 6 Mikolaj Izdebski 2014-01-06 17:29:17 EST
Fixed in tycho-0.19.0-6
Comment 7 Mikolaj Izdebski 2014-01-06 18:13:49 EST
I believe that this bug is fixed in tycho-0.19.0-6,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=488662

This bug was fixed in the next release of Fedora, and is not planned
to be fixed in the release it was filed against.  If you want this bug
to be fixed in updates for Fedora 20, please say so in a comment.
Otherwise you can update to the newer release of Fedora to get the fix.

Note You need to log in before you can comment on or make changes to this bug.