Bug 1004323 - Apper: "You have failed to provide correct authentication." while checking/installing updates
Apper: "You have failed to provide correct authentication." while checking/in...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: apper (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F20AlphaBlocker
  Show dependency treegraph
 
Reported: 2013-09-04 08:09 EDT by Martin Krizek
Modified: 2013-09-05 10:23 EDT (History)
9 users (show)

See Also:
Fixed In Version: sddm-0.2.0-0.4.20130821gite707e229.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 10:23:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Krizek 2013-09-04 08:09:52 EDT
Description of problem:
When trying to check for updates or install them, the following message is shown:
"You have failed to provide correct authentication. Please check any passwords or account settings."

Version-Release number of selected component (if applicable):
apper-0.8.1-1.fc20.x86_64
kde-workspace-4.11.0-4.fc20.x86_64
selinux-policy-3.12.1-73.fc20.x86_64
polkit-0.111-3.fc20.x86_64
polkit-kde-0.99.1-2.20130311git.fc20.x86_64

Fedora 20 Alpha TC2, DVD x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run Apper
2. Check for updates
3.

Actual results:
The above message is shown.

Expected results:
Updates are installed.
Comment 1 Martin Krizek 2013-09-04 08:11:47 EDT
Proposing as F20 Alpha blocker per criterion: "The installed system must be able to download and install updates with yum and with the default graphical package manager in all release-blocking desktops.".
Comment 2 Rex Dieter 2013-09-04 08:18:58 EDT
Can you check if any 'polkit-kde-authentication-agent-1' process is running?
Comment 3 Martin Krizek 2013-09-04 08:48:19 EDT
Yes, polkit-kde-authentication-agent-1 is running.
Comment 4 Rex Dieter 2013-09-04 09:23:56 EDT
The user running apper and experiencing this bug

* was it set or configured to be an admin user (ie, a member of the wheel group)?

* how did you login? via sddm ?  If yes,

rpm -q sddm

please.
Comment 5 Martin Krizek 2013-09-04 09:33:14 EDT
(In reply to Rex Dieter from comment #4)
> The user running apper and experiencing this bug
> 
> * was it set or configured to be an admin user (ie, a member of the wheel
> group)?

No.

> 
> * how did you login? via sddm ?  If yes,
> 
> rpm -q sddm

sddm-0.2.0-0.3.20130821gite707e229

> 
> please.
Comment 6 Rex Dieter 2013-09-04 09:42:02 EDT
Can you (re)test using sddm-0.2.0-0.4.20130821gite707e229.fc20 please?
Comment 7 Kamil PƔral 2013-09-04 12:54:05 EDT
Discussed at 2013-09-04 blocker review meeting [1]. This is accepted as an Alpha blocker, because it violates the following F20 alpha release criterion for KDE: "The installed system must be able to download and install updates with yum and with the default graphical package manager in all release-blocking desktops." [2]

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-09-04/
[2] https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Updates
Comment 8 Martin Krizek 2013-09-05 05:09:19 EDT
It seems that sddm-0.2.0-0.4.20130821gite707e229.fc20 fixes the issue.
Comment 9 Rex Dieter 2013-09-05 10:23:07 EDT
Thanks for testing.

Note You need to log in before you can comment on or make changes to this bug.