Bug 1004332 - Setting of any option using volume set fails when the clients are in older version.
Setting of any option using volume set fails when the clients are in older ve...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
urgent Severity high
: ---
: ---
Assigned To: Kaushal
:
Depends On:
Blocks: 1002871 1320377
  Show dependency treegraph
 
Reported: 2013-09-04 08:35 EDT by Kaushal
Modified: 2016-06-16 12:17 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.8.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1002871
: 1320377 (view as bug list)
Environment:
Last Closed: 2016-06-16 08:38:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaushal 2013-09-04 08:35:54 EDT
+++ This bug was initially created as a clone of Bug #1002871 +++

Describe the issue: 
===================

When Servers are in higher version than client the volume set operation fails, this was observed when the servers were in bigbend(3.4.0) base and client was in anshi(3.3.0) base. In field customers can have both 3.4.0 and 3.3.0 client accessing the same RHS servers(3.4.0)


Server: glusterfs-server-3.4.0.24rhs-1.el6rhs.x86_64 and 
client: glusterfs-3.3.0.11rhs-1.el6.x86_64

Try to set any volume option, it fails with below message. 

[root@rhs-client11 ~]# gluster volume set help | grep client-log
Option: diagnostics.client-log-level
[root@rhs-client11 ~]# gluster volume set vol-dr client-log-level DEBUG
volume set: failed: One or more connected clients cannot support the feature being set. These clients need to be upgraded or disconnected before running this command again
[root@rhs-client11 ~]# 
[root@rhs-client11 ~]# gluster volume set vol-dr cluster.metadata-self-heal off
volume set: failed: One or more connected clients cannot support the feature being set. These clients need to be upgraded or disconnected before running this command again
[root@rhs-client11 ~]# gluster volume set vol-dr cluster.data-self-heal off
volume set: failed: One or more connected clients cannot support the feature being set. These clients need to be upgraded or disconnected before running this command again
[root@rhs-client11 ~]# 
[root@rhs-client11 ~]# gluster volume set vol-dr cluster.entry-self-heal off
volume set: failed: One or more connected clients cannot support the feature being set. These clients need to be upgraded or disconnected before running this command again
[root@rhs-client11 ~]# 

The above behaviour needs to be documented.


--- Additional comment from Divya on 2013-09-03 14:31:35 IST ---

Amar,

Kindly review and sign-off the following known issue:

Issue: When Red Hat Storage Servers are of higher version and one of the client is of glusterfs-3.3.0.11rhs-1.el6.x86_64 or older version, the Volume Set operation fails.

Work Around: Upgrade your client to the latest version and ensure that all the clients are of same version.

Also, let me know if I have to clone this bug to create an eng bug? 

Thanks,
Divya
Comment 1 Anand Avati 2013-09-04 08:40:39 EDT
REVIEW: http://review.gluster.org/5786 (glusterd: Fix connected clients check during 'volume set') posted (#1) for review on master by Kaushal M (kaushal@redhat.com)
Comment 2 Anand Avati 2013-09-04 09:31:12 EDT
REVIEW: http://review.gluster.org/5786 (glusterd: Fix connected clients check during 'volume set') posted (#2) for review on master by Kaushal M (kaushal@redhat.com)
Comment 3 Anand Avati 2013-09-06 03:05:12 EDT
REVIEW: http://review.gluster.org/5829 (glusterd: Fix connected clients check during 'volume set') posted (#1) for review on release-3.4 by Kaushal M (kaushal@redhat.com)
Comment 4 Anand Avati 2015-05-26 07:37:56 EDT
REVIEW: http://review.gluster.org/5786 (glusterd: Fix connected clients check during 'volume set') posted (#3) for review on master by Kaushal M (kaushal@redhat.com)
Comment 5 Vijay Bellur 2015-11-21 09:03:39 EST
REVIEW: http://review.gluster.org/5786 (glusterd: Fix connected clients check during 'volume set') posted (#4) for review on master by Kaushal M (kaushal@redhat.com)
Comment 6 Vijay Bellur 2015-11-23 12:56:05 EST
REVIEW: http://review.gluster.org/5786 (glusterd: Fix connected clients check during 'volume set') posted (#5) for review on master by Vijay Bellur (vbellur@redhat.com)
Comment 7 Vijay Bellur 2015-11-23 12:56:24 EST
REVIEW: http://review.gluster.org/5786 (glusterd: Fix connected clients check during 'volume set') posted (#6) for review on master by Vijay Bellur (vbellur@redhat.com)
Comment 8 Vijay Bellur 2016-01-27 09:56:33 EST
REVIEW: http://review.gluster.org/5786 (glusterd: Fix connected clients check during 'volume set') posted (#7) for review on master by Kaushal M (kaushal@redhat.com)
Comment 9 Vijay Bellur 2016-03-04 01:57:12 EST
REVIEW: http://review.gluster.org/5786 (glusterd: Fix connected clients check during 'volume set') posted (#8) for review on master by Kaushal M (kaushal@redhat.com)
Comment 10 Vijay Bellur 2016-03-22 03:18:55 EDT
REVIEW: http://review.gluster.org/5786 (glusterd: Fix connected clients check during 'volume set') posted (#9) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 11 Vijay Bellur 2016-03-22 07:42:06 EDT
COMMIT: http://review.gluster.org/5786 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 2eb8758bbc88b182bf0e33506b8352cd82c7ec2e
Author: Kaushal M <kaushal@redhat.com>
Date:   Wed Sep 4 16:19:01 2013 +0530

    glusterd: Fix connected clients check during 'volume set'
    
    Use the volume's newly calulatedclient-op-version for the connected
    clients check. This prevents rejection of server options of higher
    op-version when clients of lower op-version are connected. Also,
    initialize the variables of the newly calculated volume op-version and
    client-op-version with the current values, instead of the cluster
    op-version.
    
    Change-Id: Ieb36f97c677a5457feba54bef20e154c0456e70e
    BUG: 1004332
    Signed-off-by: Kaushal M <kaushal@redhat.com>
    Reviewed-on: http://review.gluster.org/5786
    Tested-by: Atin Mukherjee <amukherj@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 12 Niels de Vos 2016-06-16 08:38:43 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 13 Niels de Vos 2016-06-16 12:17:49 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.