Bug 1004336 - kernel errors: usb 2-1.6 and hub 2-1:1.0
kernel errors: usb 2-1.6 and hub 2-1:1.0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 08:39 EDT by Claudiu
Modified: 2013-09-23 14:57 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 14:57:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Claudiu 2013-09-04 08:39:31 EDT
Description of problem:

CPU: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz

I have installed a fresh copy of Fedora 19 64bit (minimal install).
I never had similar issues with previous releases 16, 17, 18 and this is very annoying. 


In KVM console (which become inoperable until I disable the warnings), also in /var/log/messages I have lots and lots of lines like:

Sep  4 07:35:24 baba kernel: [ 1488.123458] usb 2-1.6: device descriptor read/64, error -32
Sep  4 07:35:24 baba kernel: [ 1488.299366] usb 2-1.6: device descriptor read/64, error -32
Sep  4 07:35:24 baba kernel: [ 1488.473398] usb 2-1.6: new low-speed USB device number 123 using ehci-pci
Sep  4 07:35:24 baba kernel: [ 1488.548232] usb 2-1.6: device descriptor read/64, error -32
Sep  4 07:35:24 baba kernel: [ 1488.713141] usb 2-1.6: device descriptor read/64, error -32
Sep  4 07:35:25 baba kernel: [ 1488.887047] usb 2-1.6: new low-speed USB device number 124 using ehci-pci
Sep  4 07:35:25 baba kernel: [ 1489.288700] usb 2-1.6: device not accepting address 124, error -32
Sep  4 07:35:25 baba kernel: [ 1489.361790] usb 2-1.6: new low-speed USB device number 125 using ehci-pci
Sep  4 07:35:25 baba kernel: [ 1489.763454] usb 2-1.6: device not accepting address 125, error -32
Sep  4 07:35:25 baba kernel: [ 1489.763739] hub 2-1:1.0: unable to enumerate USB device on port 6
Sep  4 07:35:30 baba kernel: [ 1494.189298] usb 2-1.6: new low-speed USB device number 126 using ehci-pci
Sep  4 07:35:30 baba kernel: [ 1494.264255] usb 2-1.6: device descriptor read/64, error -32
Sep  4 07:35:30 baba kernel: [ 1494.440163] usb 2-1.6: device descriptor read/64, error -32
Sep  4 07:35:30 baba kernel: [ 1494.614067] usb 2-1.6: new low-speed USB device number 127 using ehci-pci
Sep  4 07:35:30 baba kernel: [ 1494.689026] usb 2-1.6: device descriptor read/64, error -32
Sep  4 07:35:31 baba kernel: [ 1494.864930] usb 2-1.6: device descriptor read/64, error -32
Sep  4 07:35:31 baba kernel: [ 1495.038836] usb 2-1.6: new low-speed USB device number 5 using ehci-pci
Sep  4 07:35:31 baba kernel: [ 1495.440505] usb 2-1.6: device not accepting address 5, error -32
Sep  4 07:35:31 baba kernel: [ 1495.513738] usb 2-1.6: new low-speed USB device number 6 using ehci-pci
Sep  4 07:35:32 baba kernel: [ 1495.915251] usb 2-1.6: device not accepting address 6, error -32
Sep  4 07:35:32 baba kernel: [ 1495.915528] hub 2-1:1.0: unable to enumerate USB device on port 6




Version-Release number of selected component (if applicable):
latest kernel 3.10.10-200.fc19.x86_64 #1 SMP


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Michele Baldessari 2013-09-04 18:00:53 EDT
Hi Giuliano,

can you let us know if downgrading the kernel to 3.9 fixes the issue?
Then we can further investigate which change broke this for you.

Thanks,
Michele
Comment 2 Claudiu 2013-09-05 08:16:55 EDT
I had initial setup with 3.9.5 version with the same errors. I have updated everything with "yum update" thinking that the newest version will solve the problems.
Comment 3 Michele Baldessari 2013-09-05 16:33:02 EDT
Hi Giuliano,

so this specific device never worked or is there a kernel version where it 
did work?

You could quickly check if 3.11 fixed it for you:
https://fedoraproject.org/wiki/RawhideKernelNodebug

regards,
Michele
Comment 4 Claudiu 2013-09-05 17:27:29 EDT
Hmm, it may have something to do with USB from KVM console because messages disappeared when KVM was disconnected. 
I have upgraded to 3.11.0-2.fc21.x86_64 #1 SMP, reconnected KVM and I no longer have such kind of messages in logs. 



Sep  5 16:15:47 baba kernel: [  553.610186] usb 2-1.6: new low-speed USB device number 3 using ehci-pci
Sep  5 16:15:47 baba kernel: [  553.705557] usb 2-1.6: New USB device found, idVendor=0a81, idProduct=0205
Sep  5 16:15:47 baba kernel: [  553.705561] usb 2-1.6: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Sep  5 16:15:47 baba kernel: [  553.705564] usb 2-1.6: Product: PS2 to USB Converter
Sep  5 16:15:47 baba kernel: [  553.705566] usb 2-1.6: Manufacturer: CHESEN
Sep  5 16:15:47 baba kernel: [  553.712806] input: CHESEN PS2 to USB Converter as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0/input/input4
Sep  5 16:15:47 baba kernel: [  553.712964] hid-generic 0003:0A81:0205.0001: input,hidraw0: USB HID v1.10 Keyboard [CHESEN PS2 to USB Converter] on usb-0000:00:1d.0-1.6/input0
Sep  5 16:15:47 baba kernel: [  553.720913] input: CHESEN PS2 to USB Converter as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.1/input/input5
Sep  5 16:15:47 baba kernel: [  553.721225] hid-generic 0003:0A81:0205.0002: input,hidraw1: USB HID v1.10 Mouse [CHESEN PS2 to USB Converter] on usb-0000:00:1d.0-1.6/input1
Sep  5 16:16:52 baba kernel: [  618.589218] usb 2-1.3: new full-speed USB device number 4 using ehci-pci
Sep  5 16:16:52 baba kernel: [  618.676888] usb 2-1.3: New USB device found, idVendor=14dd, idProduct=0002
Sep  5 16:16:52 baba kernel: [  618.676894] usb 2-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Sep  5 16:16:52 baba kernel: [  618.676897] usb 2-1.3: Product: Multidevice
Comment 5 Josh Boyer 2013-09-18 16:35:47 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 6 Michele Baldessari 2013-09-20 04:00:58 EDT
Hi Giuliano,

so the issue is gone with 3.11 correct? If yes can you close this case?

Thanks,
Michele
Comment 7 Claudiu 2013-09-23 14:57:54 EDT
Yes, I no longer have any issue.

Note You need to log in before you can comment on or make changes to this bug.