Bug 1004358 - Dashboard throws errors on deployment: "Error in load() SQLDataset." and "Error serializing data provider: null"
Dashboard throws errors on deployment: "Error in load() SQLDataset." and "Err...
Status: CLOSED WONTFIX
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: BAM (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ER4
: 6.0.0
Assigned To: David Gutierrez
Jiri Svitak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 09:19 EDT by Jiri Svitak
Modified: 2015-06-01 21:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-18 09:59:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (119.31 KB, text/plain)
2013-09-04 09:19 EDT, Jiri Svitak
no flags Details
mysql-ds.xml (490 bytes, text/plain)
2013-09-04 09:23 EDT, Jiri Svitak
no flags Details

  None (edit)
Description Jiri Svitak 2013-09-04 09:19:45 EDT
Created attachment 793666 [details]
server.log

BPMS ER2 deployment throws these errors:

15:06:11,621 ERROR [org.jboss.dashboard.dataset.sql.SQLDataSet] (ServerService Thread Pool -- 55) Error in load() SQLDataset. SQL = select total.processname, coalesce(total.instances,0) total, coalesce(active.instances_act,0) active, coalesce(completed.instances_compl,0) completed, coalesce(pending.instances_pend,0) pending, coalesce(suspended.instances_susp,0) suspended, coalesce(aborted.instances_abrt,0) aborted

...

15:06:11,629 ERROR [org.jboss.dashboard.provider.DataProviderImpl] (ServerService Thread Pool -- 55) Error serializing data provider: null: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Table 'bpms.processinstancelog' doesn't exist

...

15:06:11,646 ERROR [org.jboss.dashboard.dataset.sql.SQLDataSet] (ServerService Thread Pool -- 55) Error in load() SQLDataset. SQL = select total.processname, coalesce(total.instances,0) total, coalesce(active.instances_act,0) active, coalesce(completed.instances_compl,0) completed, coalesce(pending.instances_pend,0) pending, coalesce(suspended.instances_susp,0) suspended, coalesce(aborted.instances_abrt,0) aborted

To reproduce:
1.) Download BPMS 6 ER2 and merge it with JBoss EAP 6.1.
2.) Setup user guest, with password guest. Hint:
guest=b5d048a237bfd2874b6928e1f37ee15e
guest=kie-user,ADMIN
3.) Configure both business-central.war and dashbuilder.war to use MySQL database. Add mysql-connector-java-5.1.26-bin.jar and mysql-ds.xml to ${EAP_DIR}/standalone/deployments to deploy a MySQL datasource. Change DS name to java:jboss/datasources/mysqlDS and hibernate dialect to org.hibernate.dialect.MySQL5InnoDBDialect in dashbuilder.war/WEB-INF/jboss-web.xml and business-central.war/WEB-INF/classes/META-INF/persistence.xml.
4.) Run it with
cd ${EAP_DIR}/bin
./standalone.sh

My environment:
BPMS 6 ER2
JBoss EAP 6.1
MySQL 5.5.32
mysql-connector-java-5.1.26-bin.jar driver
Comment 1 Jiri Svitak 2013-09-04 09:23:27 EDT
Created attachment 793668 [details]
mysql-ds.xml

Please setup your local database to match information in this data source.
Comment 2 David Gutierrez 2013-09-09 06:49:12 EDT
Those kind of errors are raised when the jbpm-dashboard is NOT deployed right after kie-wb. Please, review the deployment order and ensure the jBPM database schema is available before deploying the jbpm-dashboard as explained here:

 https://github.com/droolsjbpm/jbpm-dashboard/blob/master/jbpm-dashboard-distributions/src/main/jbossas7/README.md)
Comment 6 Jiri Svitak 2013-10-18 09:59:24 EDT
According to steps mentioned by David, this is not a bug, but a product feature. User needs to follow the specific deployment steps to make sure such errors are not thrown.

Closing as this won't be changed.

Note You need to log in before you can comment on or make changes to this bug.