Bug 1004375 - Cannot run process with timer via JMS: "Error when executing timer job: java.lang.NullPointerException"
Cannot run process with timer via JMS: "Error when executing timer job: java....
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ER4
: 6.0.0
Assigned To: Marco Rietveld
Jiri Svitak
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 09:58 EDT by Jiri Svitak
Modified: 2016-09-20 01:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:09:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (29.69 KB, text/plain)
2013-09-04 09:58 EDT, Jiri Svitak
no flags Details
mysql-ds.xml (490 bytes, text/plain)
2013-09-04 09:59 EDT, Jiri Svitak
no flags Details

  None (edit)
Description Jiri Svitak 2013-09-04 09:58:02 EDT
Created attachment 793686 [details]
server.log

Cannot run a process with timer via JMS: "Error when executing timer job: java.lang.NullPointerException". To see all stack traces see the attached server.log

To reproduce:
1.) Download BPMS 6 ER2 and merge it with JBoss EAP 6.1.
2.) Setup user guest, with password guest. Hint:
guest=b5d048a237bfd2874b6928e1f37ee15e
guest=kie-user,ADMIN
3.) Configure both business-central.war and dashbuilder.war to use MySQL database. Add mysql-connector-java-5.1.26-bin.jar and mysql-ds.xml to ${EAP_DIR}/standalone/deployments to deploy a MySQL datasource. Change DS name to java:jboss/datasources/mysqlDS and hibernate dialect to org.hibernate.dialect.MySQL5InnoDBDialect in dashbuilder.war/WEB-INF/jboss-web.xml and business-central.war/WEB-INF/classes/META-INF/persistence.xml.
4.) Run it with
cd ${EAP_DIR}/bin
./standalone.sh
5.) Install PerfCake 1.0-SNAPSHOT
git clone https://github.com/PerfCake/PerfCake.git
cd PerfCake
git checkout devel
mvn clean install -DskipTests
6.) Run perf scenario, just two iterations are enough to break:
git clone git://git.app.eng.bos.redhat.com/jbossqe-process-flood.git
cd jbossqe-process-flood/bpms-6.x
./execute_scenario.sh -Dscenario=Timer_JMS -DrunType=iteration -Dduration=2

My environment:
BPMS 6 ER2
JBoss EAP 6.1
MySQL 5.5.32
mysql-connector-java-5.1.26-bin.jar driver
Comment 1 Jiri Svitak 2013-09-04 09:59:19 EDT
Created attachment 793687 [details]
mysql-ds.xml

MySQL datasource used by business-central.
Comment 2 Jiri Svitak 2013-09-05 04:31:15 EDT
In the reproduce steps I forgot to mention role configuration for JMS. Open standalone.xml, find subsystem messaging->security settings and add there role kie-user.
Comment 3 Marco Rietveld 2013-09-05 08:34:51 EDT
This is related to both BZ 999149 and BZ 1002724 (which is actually BZ 1002554). Could you confirm whether or not this is a duplicate of those problems?
Comment 7 Jiri Svitak 2013-10-15 11:27:29 EDT
Verified in BPMS 6 ER4.
Comment 8 Marco Rietveld 2013-10-16 04:59:34 EDT
Great! Thanks, Jiri.

Note You need to log in before you can comment on or make changes to this bug.