Bug 1004420 - Backport qcow2 corruption prevention patches
Backport qcow2 corruption prevention patches
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.6
Unspecified Unspecified
medium Severity high
: rc
: ---
Assigned To: Max Reitz
Virtualization Bugs
:
Depends On: 1004347
Blocks: 1002699
  Show dependency treegraph
 
Reported: 2013-09-04 11:23 EDT by Kevin Wolf
Modified: 2014-12-11 11:13 EST (History)
13 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.427.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1004347
Environment:
Last Closed: 2014-10-14 02:50:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Wolf 2013-09-04 11:23:01 EDT
Once the RHEL 6.6 tree is open, it would be useful to have it backported there
as well. As it's only prevention, we'll not include it in 6.5.


+++ This bug was initially created as a clone of Bug #1004347 +++

Upstream commits d4ca092a to ca0eca91 implements sanity checks for writes to a
qcow2 image as follows:

> If a qcow2 image file becomes corrupted, any write may inadvertently
> overwrite important metadata structures such as the L1 table. This
> series adds functionality for detecting, preventing and (to some extent)
> repairing such collisions.

This is something that we'll want to have in RHEL 7.
Comment 1 Ayal Baron 2014-01-29 05:03:33 EST
Please note that this bug affects RHEV customers and we would like to see this in 6.6
Thanks.
Comment 6 Jeff Nelson 2014-05-23 14:08:10 EDT
Fix included in qemu-kvm-0.12.1.2-2.427.el6
Comment 16 Sibiao Luo 2014-08-11 04:58:10 EDT
Verify this issue.

host info:
# uname -r && rpm -q qemu-kvm
2.6.32-491.el6.x86_64
qemu-kvm-0.12.1.2-2.436.el6.x86_64

# rpm -ivh qemu-kvm-0.12.1.2-2.436.el6.src.rpm
# rpmbuild -bp --nodeps /root/rpmbuild/SPECS/qemu-kvm.spec
# tar -zxvf /root/rpmbuild/SOURCES/qemu-kvm-0.12.1.2.tar.gz
qemu-iotests]# pwd
/root/rpmbuild/BUILD/qemu-kvm-0.12.1.2/tests/qemu-iotests
qemu-iotests]# export QEMU_PROG=/usr/libexec/qemu-kvm

qemu-iotests]# ./check -qcow2 060
QEMU          -- /usr/libexec/qemu-kvm
QEMU_IMG      -- /usr/bin/qemu-img
QEMU_IO       -- /usr/bin/qemu-io 
QEMU_NBD      -- 
IMGFMT        -- qcow2
IMGPROTO      -- file
PLATFORM      -- Linux/x86_64 intel-5504-12-2 2.6.32-491.el6.x86_64
SOCKET_SCM_HELPER -- 

060        
Passed all 1 tests

According to above, comment #13 and comment #15, set this issue to VERIFIED status.
Comment 17 errata-xmlrpc 2014-10-14 02:50:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1490.html

Note You need to log in before you can comment on or make changes to this bug.