Bug 1004441 - [abrt] WARNING: at drivers/gpu/drm/i915/intel_display.c:979 intel_wait_for_pipe_off+0xfb/0x1c0 [i915]()
[abrt] WARNING: at drivers/gpu/drm/i915/intel_display.c:979 intel_wait_for_pi...
Status: CLOSED DUPLICATE of bug 958982
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
abrt_hash:3332d00e8fd12e90e0b27b0ed59...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 12:03 EDT by Michal Hlavinka
Modified: 2013-12-09 12:13 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 12:13:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (76.08 KB, text/plain)
2013-09-04 12:03 EDT, Michal Hlavinka
no flags Details

  None (edit)
Description Michal Hlavinka 2013-09-04 12:03:48 EDT
Description of problem:
dual head setup, changed resolution of one screen

Additional info:
reporter:       libreport-2.1.6
WARNING: at drivers/gpu/drm/i915/intel_display.c:979 intel_wait_for_pipe_off+0xfb/0x1c0 [i915]()
pipe_off wait timed out
Modules linked in: vhost_net macvtap macvlan hidp ebtable_nat xt_CHECKSUM tun nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 bridge nf_defrag_ipv6 stp llc iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables rfcomm bnep snd_hda_codec_hdmi snd_hda_codec_realtek iTCO_wdt iTCO_vendor_support mperf coretemp arc4 iwldvm snd_hda_intel mac80211 kvm_intel kvm snd_hda_codec snd_hwdep snd_seq snd_seq_device microcode uvcvideo iwlwifi snd_pcm btusb videobuf2_vmalloc videobuf2_memops bluetooth videobuf2_core videodev e1000e media sdhci_pci snd_page_alloc joydev sdhci thinkpad_acpi cfg80211 i2c_i801 lpc_ich mmc_core tpm_tis snd_timer snd mei_me ptp mfd_core pps_core mei tpm soundcore rfkill wmi tpm_bios binfmt_misc uinput dm_crypt crc32_pclmul crc32c_intel i915 ghash_clmulni_intel i2c_algo_bit drm_kms_helper drm i2c_core video
CPU: 3 PID: 1209 Comm: X Not tainted 3.10.10-200.fc19.x86_64 #1
Hardware name: LENOVO 2429BP3/2429BP3, BIOS G4ET92WW (2.52 ) 02/01/2013
 0000000000000009 ffff88030bc0bb80 ffffffff81639647 ffff88030bc0bbb8
 ffffffff8105c221 0000000000071008 ffff88030a958000 0000000105aa8c2c
 ffff88030bc0bfd8 ffff88030a958000 ffff88030bc0bc18 ffffffff8105c28c
Call Trace:
 [<ffffffff81639647>] dump_stack+0x19/0x1b
 [<ffffffff8105c221>] warn_slowpath_common+0x61/0x80
 [<ffffffff8105c28c>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffffa0081e36>] ? i915_read32+0x66/0x140 [i915]
 [<ffffffffa00a8b6b>] intel_wait_for_pipe_off+0xfb/0x1c0 [i915]
 [<ffffffffa00a8dc4>] intel_disable_pipe+0x194/0x220 [i915]
 [<ffffffffa00a9736>] ironlake_crtc_disable+0xc6/0x8d0 [i915]
 [<ffffffffa00adcbf>] intel_crtc_update_dpms+0x6f/0xa0 [i915]
 [<ffffffffa00add8a>] intel_encoder_dpms+0x1a/0x30 [i915]
 [<ffffffffa00b2ae8>] intel_connector_dpms+0x38/0x70 [i915]
 [<ffffffffa003cf68>] drm_mode_obj_set_property_ioctl+0x308/0x320 [drm]
 [<ffffffffa003cfb0>] drm_mode_connector_property_set_ioctl+0x30/0x40 [drm]
 [<ffffffffa002c2c2>] drm_ioctl+0x532/0x670 [drm]
 [<ffffffff811a9a25>] do_vfs_ioctl+0x305/0x520
 [<ffffffff8128b22e>] ? file_has_perm+0x8e/0xa0
 [<ffffffff8119990e>] ? ____fput+0xe/0x10
 [<ffffffff811a9cc1>] SyS_ioctl+0x81/0xa0
 [<ffffffff81647c59>] system_call_fastpath+0x16/0x1b
Comment 1 Michal Hlavinka 2013-09-04 12:03:55 EDT
Created attachment 793746 [details]
File: dmesg
Comment 2 Daniel Vetter 2013-09-20 17:34:03 EDT
Does this happen when changing the resolution of a DisplayPort screen? Also please attach the output of lspci -nn to figure out the chipset id.
Comment 3 Michal Hlavinka 2013-09-23 10:01:02 EDT
Hi,
yes, I have second screen (third in fact, laptop lcd is turned off) connected via DisplayPort.

lspci:
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)

Anyway, I just tried to reproduce it and I was not able to trigger this problem.
Comment 4 Adam Jackson 2013-12-09 12:13:06 EST

*** This bug has been marked as a duplicate of bug 958982 ***

Note You need to log in before you can comment on or make changes to this bug.