Bug 1004444 - Missing documentation about management CLI setting
Missing documentation about management CLI setting
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: GA
: EAP 6.3.0
Assigned To: eap-docs
Russell Dickenson
: Documentation, FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 12:07 EDT by FIlip Bogyai
Modified: 2015-12-01 00:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-28 11:40:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description FIlip Bogyai 2013-09-04 12:07:34 EDT
Title: The Management CLI

Section does not cover possible settings for Management CLI.

CLI client is configured by jboss-cli.xml file, which is by default loaded from JBOSS_HOME/bin directory or from path in system property "jboss.cli.config"
Additional information: https://issues.jboss.org/browse/AS7-5241

Configuration settings for jboss-cli.xml file are listed here: https://access.redhat.com/site/solutions/427163

We need to have these information in documentation, because it is related to RFE- EAP62_2030.
Comment 1 Russell Dickenson 2014-05-23 00:23:10 EDT
I propose to add a topic "Management CLI Configuration Options" to the existing A&C Guide content specification as follows:

Reference of Management CLI Commands [5246]
Reference of Management CLI Operations [5486]
Management CLI Configuration Options  <-------


Documentation will be sourced from the file $JBOSS_HOME/docs/schema/jboss-as-cli_1_3.xsd
Comment 2 Russell Dickenson 2014-05-23 00:41:15 EDT
I created the following topic: Management CLI Configuration Options [31362]
Comment 3 Russell Dickenson 2014-05-26 00:53:24 EDT
I have added documentation of the management CLI configuration options to the Admin & Config Guide, as indicated in comment 1. When the guide is rebuilt I will change this ticket to ON_QA.
Comment 4 Russell Dickenson 2014-05-27 00:09:40 EDT
The new text is available for verification i revision 6.3.0-19 (or higher) of the Admin & Config Guide at [1].

[1] http://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6.3/html-single/Administration_and_Configuration_Guide/index.html#Management_CLI_Configuration_Options
Comment 5 FIlip Bogyai 2014-05-27 07:32:34 EDT
Verified in Revision 6.3.0-19.

Note You need to log in before you can comment on or make changes to this bug.