Bug 1004484 - Unable to fast switch users from gnome when using KDM
Unable to fast switch users from gnome when using KDM
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdm (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 14:03 EDT by Michal Domonkos
Modified: 2014-10-14 04:20 EDT (History)
1 user (show)

See Also:
Fixed In Version: gdm-2.30.4-54.el6
Doc Type: Bug Fix
Doc Text:
Cause: "Switch User" menu item depends on the GDM display manager for bringing up a login screen to switch users Consequence: The "Switch User" menu item fails if a user initially logged in with KDM Fix: The "Switch User" menu item is now hidden if the user didn't log in with GDM. Result: A broken menu item is no longer presented to the user taunting them.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 04:20:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Domonkos 2013-09-04 14:03:10 EDT
Description of problem:
Fast user switching in GNOME does not work when having KDM set as the default display manager. An attempt to switch a user via the applet causes an error message to pop out.

Version-Release number of selected component (if applicable):
gdm-2.30.4-39.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Have at least two users set up
2. Put DISPLAYMANAGER="KDE" in /etc/sysconfig/desktop
3. Run: initctl restart prefdm
4. Log into a GNOME session
5. Click the user switch applet and "Switch User"

Actual results:
Error message "Unable to start new display - The name org.gnome.DisplayManager was not provided by any .service files".

Expected results:
KDM login should be displayed.
Comment 1 Ray Strode [halfline] 2014-04-03 09:16:12 EDT
devack+ to hiding the user switch feature if GDM isn't running.
Comment 4 errata-xmlrpc 2014-10-14 04:20:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1591.html

Note You need to log in before you can comment on or make changes to this bug.