Bug 1004498 - error trying to load metrics in UI
error trying to load metrics in UI
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Monitoring (Show other bugs)
4.8
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: RHQ 4.9
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 14:28 EDT by John Mazzitelli
Modified: 2013-09-04 15:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-04 15:13:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2013-09-04 14:28:33 EDT
I installed cleanly a master build from this morning. I rhqctl install, I go to the UI, and I go to the platform resource. The availability data shows all grey UNKnOWN and the table of data is empty, but it has a spinning "loading" icon.

In the firebug console I see:

WARNING: Error retrieving recent metrics charting data for resource [10001]:[1378318567408] javax.ejb.EJBException:java.lang.IllegalArgumentException: highValue (1.286643712E9) is not greater than or equal to value (1.8222993635555558E9). -> java.lang.IllegalArgumentException:highValue (1.286643712E9) is not greater than or equal to value (1.8222993635555558E9).88AF9B...he.html (line 5580)

The error is in the server, and I see the stack trace:

14:16:07,408 WARN  [org.rhq.enterprise.gui.coregui.server.gwt.MeasurementDataGWTServiceImpl] (http-/0.0.0.0:7080-10) Sending exception to client: [1378318567408] : javax.ejb.EJBException: java.lang.IllegalArgumentException: highValue (1.286643712E9) is not greater than or equal to value (1.8222993635555558E9).
...
	at org.rhq.enterprise.server.measurement.MeasurementDataManagerLocal$$$view122.findDataForResource(Unknown Source) [rhq-server.jar:4.9.0-SNAPSHOT]
	at org.rhq.enterprise.gui.coregui.server.gwt.MeasurementDataGWTServiceImpl.findDataForResource(MeasurementDataGWTServiceImpl.java:111) [classes:]
...
	at com.google.gwt.user.server.rpc.RPC.invokeAndEncodeResponse(RPC.java:561) [gwt-servlet-2.5.0.jar:]
...
	at org.rhq.enterprise.gui.coregui.server.gwt.AbstractGWTServiceImpl.service(AbstractGWTServiceImpl.java:89) [classes:]
...
Caused by: java.lang.IllegalArgumentException: highValue (1.286643712E9) is not greater than or equal to value (1.8222993635555558E9).
	at org.rhq.core.domain.measurement.composite.MeasurementDataNumericHighLowComposite.<init>(MeasurementDataNumericHighLowComposite.java:44) [rhq-core-domain-ejb3.jar:4.9.0-SNAPSHOT]
	at org.rhq.server.metrics.MetricsServer.createComposites(MetricsServer.java:285) [rhq-server-metrics-4.9.0-SNAPSHOT.jar:4.9.0-SNAPSHOT]
	at org.rhq.server.metrics.MetricsServer.findDataForResource(MetricsServer.java:164) [rhq-server-metrics-4.9.0-SNAPSHOT.jar:4.9.0-SNAPSHOT]
	at org.rhq.enterprise.server.measurement.MeasurementDataManagerBean.findDataForResource(MeasurementDataManagerBean.java:811) [rhq-server.jar:4.9.0-SNAPSHOT]
	at sun.reflect.GeneratedMethodAccessor274.invoke(Unknown Source) [:1.7.0_11]
...
Comment 1 John Mazzitelli 2013-09-04 14:43:06 EDT
this was first mentioned in this forum thread:

https://community.jboss.org/message/836122#836122

but I can't get the schedule ID that  I need to get John the data he asks for. The error message and stack do not provide me with the schedule Id. The code here should be modified - the error message or log messages or both should say which schedule ID caused the problem.
Comment 2 John Mazzitelli 2013-09-04 15:13:22 EDT
turns out, I rebuilt using -Ddbsetup but I did not also clean my storage node data which I had collected over the past few days.

So my RDBMS got new data (new schedules, inventory, etc) but the old metric data from days ago existed.

I'm pretty sure that's the problem. But even if not, nothing I do with this server wrt metrics can be trusted since my datastores are not in sync. I'm closing this.

Note You need to log in before you can comment on or make changes to this bug.