Bug 1004501 - [abrt] mate-file-manager-1.6.2-3.fc18: strlen: Process /usr/bin/caja was killed by signal 11 (SIGSEGV)
[abrt] mate-file-manager-1.6.2-3.fc18: strlen: Process /usr/bin/caja was kill...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mate-file-manager-open-terminal (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
abrt_hash:7795d4e348f96c495a21ec96830...
:
: 1008064 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 14:55 EDT by Dennis W. Tokarski
Modified: 2013-10-05 21:36 EDT (History)
4 users (show)

See Also:
Fixed In Version: mate-file-manager-open-terminal-1.6.0-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 21:13:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (33.67 KB, text/plain)
2013-09-04 14:55 EDT, Dennis W. Tokarski
no flags Details
File: cgroup (129 bytes, text/plain)
2013-09-04 14:55 EDT, Dennis W. Tokarski
no flags Details
File: core_backtrace (4.12 KB, text/plain)
2013-09-04 14:55 EDT, Dennis W. Tokarski
no flags Details
File: dso_list (10.55 KB, text/plain)
2013-09-04 14:55 EDT, Dennis W. Tokarski
no flags Details
File: environ (1.59 KB, text/plain)
2013-09-04 14:55 EDT, Dennis W. Tokarski
no flags Details
File: limits (1.29 KB, text/plain)
2013-09-04 14:55 EDT, Dennis W. Tokarski
no flags Details
File: maps (53.84 KB, text/plain)
2013-09-04 14:55 EDT, Dennis W. Tokarski
no flags Details
File: open_fds (3.19 KB, text/plain)
2013-09-04 14:55 EDT, Dennis W. Tokarski
no flags Details
File: proc_pid_status (937 bytes, text/plain)
2013-09-04 14:55 EDT, Dennis W. Tokarski
no flags Details
File: var_log_messages (14.14 KB, text/plain)
2013-09-04 14:55 EDT, Dennis W. Tokarski
no flags Details
File: xsession_errors (148 bytes, text/plain)
2013-09-04 14:55 EDT, Dennis W. Tokarski
no flags Details

  None (edit)
Description Dennis W. Tokarski 2013-09-04 14:55:00 EDT
Description of problem:
Open caja, navigate to a directory on another host  using sftp,
e.g., ssh://someotherhost/home/foo.

Enter credentials when prompted and wait for remote directory
content to appear in main pane. Then right click in pane to get
the context menu, click on "Open in Terminal".

Caja will instantly sigsegv, every time.

This does not happen when viewing a local directory.

Version-Release number of selected component:
mate-file-manager-1.6.2-3.fc18

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        caja -n
crash_function: strlen
executable:     /usr/bin/caja
kernel:         3.10.7-100.fc18.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 strlen at ../sysdeps/x86_64/strlen.S:31
 #1 __strdup at strdup.c:41
 #2 parse_sftp_uri at caja-open-terminal.c:217
 #3 append_sftp_info at caja-open-terminal.c:245
 #4 open_terminal_callback at caja-open-terminal.c:315
 #5 _g_closure_invoke_va at gclosure.c:840
 #12 _gtk_action_emit_activate at gtkaction.c:795
 #13 _g_closure_invoke_va at gclosure.c:840
 #16 gtk_widget_activate at gtkwidget.c:5048
 #17 gtk_menu_shell_activate_item at gtkmenushell.c:1303
Comment 1 Dennis W. Tokarski 2013-09-04 14:55:05 EDT
Created attachment 793788 [details]
File: backtrace
Comment 2 Dennis W. Tokarski 2013-09-04 14:55:08 EDT
Created attachment 793789 [details]
File: cgroup
Comment 3 Dennis W. Tokarski 2013-09-04 14:55:12 EDT
Created attachment 793790 [details]
File: core_backtrace
Comment 4 Dennis W. Tokarski 2013-09-04 14:55:15 EDT
Created attachment 793791 [details]
File: dso_list
Comment 5 Dennis W. Tokarski 2013-09-04 14:55:19 EDT
Created attachment 793792 [details]
File: environ
Comment 6 Dennis W. Tokarski 2013-09-04 14:55:22 EDT
Created attachment 793793 [details]
File: limits
Comment 7 Dennis W. Tokarski 2013-09-04 14:55:26 EDT
Created attachment 793794 [details]
File: maps
Comment 8 Dennis W. Tokarski 2013-09-04 14:55:32 EDT
Created attachment 793795 [details]
File: open_fds
Comment 9 Dennis W. Tokarski 2013-09-04 14:55:35 EDT
Created attachment 793796 [details]
File: proc_pid_status
Comment 10 Dennis W. Tokarski 2013-09-04 14:55:39 EDT
Created attachment 793797 [details]
File: var_log_messages
Comment 11 Dennis W. Tokarski 2013-09-04 14:55:42 EDT
Created attachment 793798 [details]
File: xsession_errors
Comment 12 Wolfgang Ulbrich 2013-09-09 06:28:46 EDT
Thanks for reporting.
Unfortunately i can't confirm this issue.
If i connect with sftp to my fedorapeople account i can open a terminal without a problem from the right click menu.
Comment 13 Dennis W. Tokarski 2013-09-09 13:05:38 EDT
Hi Wolfgang,

Thanks for trying to duplicate this.

I actually have two Fedora 18 boxes at slightly differing revision
levels, which exhibit this problem. The one reported here is running
mate-file-manager-1.6.2-3.fc18.x86_64, the other is running
mate-file-manager-1.6.1-9.fc18.x86_64.

Each experiences this caja crash attempting to open a terminal when
viewing a directory via sftp on either a Fedora 14 system or on the
other Fedora 18 system. Also, if caja is showing sftp://localhost/
and I try to open a terminal, it crashes. The viewed files don't have
to actually be remote; it seems all that's needed is to use sftp.

btw, I notice that in my old Fedora 14 system, the nautilus context
menu has both "open local terminal" and "open remote terminal" choices.
Is current caja based on an older nautilus?

Is there anything else I can do to collect more information you'd
find helpful?

Eventually it might be necessary to build from the source rpm and
fire up the debugger. Hmmmm...I have a Fedora 19 live DVD around
here somewhere, I'll try that to see if the problem is there too
and let you know.
Comment 14 Wolfgang Ulbrich 2013-09-14 06:45:29 EDT
(In reply to Dennis W. Tokarski from comment #13)
> Hi Wolfgang,
> 
> Thanks for trying to duplicate this.
> 
> I actually have two Fedora 18 boxes at slightly differing revision
> levels, which exhibit this problem. The one reported here is running
> mate-file-manager-1.6.2-3.fc18.x86_64, the other is running
> mate-file-manager-1.6.1-9.fc18.x86_64.
Does this mean it happens not with mate-file-manager-1.6.1-9.fc18.x86_64 ?
> 
> Each experiences this caja crash attempting to open a terminal when
> viewing a directory via sftp on either a Fedora 14 system or on the
> other Fedora 18 system. Also, if caja is showing sftp://localhost/
> and I try to open a terminal, it crashes. The viewed files don't have
> to actually be remote; it seems all that's needed is to use sftp.
Confirmed, using sftp://localhost/ and open a terminal crashed caja too on my f18 system.
https://bugzilla.redhat.com/show_bug.cgi?id=1008064
> 
> btw, I notice that in my old Fedora 14 system, the nautilus context
> menu has both "open local terminal" and "open remote terminal" choices.
> Is current caja based on an older nautilus?
Long time ago that i use gnome2 in f14 ;) I can't remember.
Basicly caja is based on nautilus-2.31.x, but during the gsetting port a lot is changed.
> 
> Is there anything else I can do to collect more information you'd
> find helpful?
> 
> Eventually it might be necessary to build from the source rpm and
> fire up the debugger. Hmmmm...I have a Fedora 19 live DVD around
> here somewhere, I'll try that to see if the problem is there too
> and let you know.
Comment 15 Wolfgang Ulbrich 2013-09-14 06:47:17 EDT
*** Bug 1008064 has been marked as a duplicate of this bug. ***
Comment 16 Wolfgang Ulbrich 2013-09-14 06:55:04 EDT
Maybe we have a permission problem because i did create with caja-actions a menu entry 'open as root'. With this entry caja didn't crash on sftp://localhost/
Comment 17 Wolfgang Ulbrich 2013-09-14 06:57:05 EDT
i me(In reply to Wolfgang Ulbrich from comment #16)
> Maybe we have a permission problem because i did create with caja-actions a
> menu entry 'open as root'. With this entry caja didn't crash on
> sftp://localhost/

I meant an entry 'open a terminal as root'.
Comment 18 Wolfgang Ulbrich 2013-09-14 07:17:05 EDT
Ok, it seems to be a problem with mate-file-manager-open-terminal.
If i create a action rule with caja-actions for a terminal (with user rights), open the terminal with this entry works like a charm.
I suggest to do the same as workaround until this issue is fixed from upstream.
Use this Parameter '--working-directory=%F' for mate-terminal 
for creating an action in caja-actions.
Comment 19 Wolfgang Ulbrich 2013-09-14 08:28:25 EDT
I informed upstream about the issue.
https://github.com/mate-desktop/mate-file-manager-open-terminal/issues/9
Comment 20 Fedora Update System 2013-09-26 09:05:56 EDT
mate-file-manager-open-terminal-1.6.0-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-file-manager-open-terminal-1.6.0-4.fc19
Comment 21 Fedora Update System 2013-09-26 09:06:07 EDT
mate-file-manager-open-terminal-1.6.0-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mate-file-manager-open-terminal-1.6.0-4.fc20
Comment 22 Fedora Update System 2013-09-26 09:06:16 EDT
mate-file-manager-open-terminal-1.6.0-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-file-manager-open-terminal-1.6.0-4.fc18
Comment 23 Fedora Update System 2013-09-26 20:38:22 EDT
Package mate-file-manager-open-terminal-1.6.0-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-file-manager-open-terminal-1.6.0-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17702/mate-file-manager-open-terminal-1.6.0-4.fc19
then log in and leave karma (feedback).
Comment 24 Fedora Update System 2013-10-02 21:13:12 EDT
mate-file-manager-open-terminal-1.6.0-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 25 Fedora Update System 2013-10-05 21:27:27 EDT
mate-file-manager-open-terminal-1.6.0-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 Fedora Update System 2013-10-05 21:36:12 EDT
mate-file-manager-open-terminal-1.6.0-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.