Bug 1004515 - Python 2.7 default application template has references to python-2.6
Python 2.7 default application template has references to python-2.6
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rob Millner
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 15:53 EDT by Mrunal Patel
Modified: 2015-05-14 19:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-19 12:49:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mrunal Patel 2013-09-04 15:53:07 EDT
Description of problem:
[mrunal@localhost py1]$ head wsgi/application 
#!/usr/bin/python
import os

virtenv = os.environ['OPENSHIFT_PYTHON_DIR'] + '/virtenv/'
os.environ['PYTHON_EGG_CACHE'] = os.path.join(virtenv, 'lib/python2.6/site-packages')
virtualenv = os.path.join(virtenv, 'bin/activate_this.py')
try:
    execfile(virtualenv, dict(__file__=virtualenv))
except IOError:
    pass
[mrunal@localhost py1]$ 


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Create a python 2.7 application.
2. See the contents of wsgi/application file.


Actual results:
os.environ['PYTHON_EGG_CACHE'] = os.path.join(virtenv, 'lib/python2.6/site-packages')


Expected results:
There should be no reference to python-2.6
Comment 1 Rob Millner 2013-09-05 15:21:26 EDT
Pull request:
https://github.com/openshift/origin-server/pull/3555
Comment 2 openshift-github-bot 2013-09-05 17:15:41 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/03f2b6d89689da976045d94b3740022abf83f2ae
Bug 1004515 - PYTHON_EGG_CACHE is passed in from the environment and does not need to hardcode.
Comment 3 chunchen 2013-09-05 23:26:50 EDT
The issue is reproduced on devenv_3749.
Comment 4 chunchen 2013-09-06 03:49:25 EDT
Checked this issue on devenv_3752 again, it's fixed,so change the stauts to ON_QA -> VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.