This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1004555 - IPA cannot remove disconnected replica data to reconnect
IPA cannot remove disconnected replica data to reconnect
Status: CLOSED DUPLICATE of bug 1001662
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Martin Kosek
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 18:41 EDT by Michael Gregg
Modified: 2014-08-05 07:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 05:00:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Gregg 2013-09-04 18:41:29 EDT
Description of problem:
This is a possible regression of https://bugzilla.redhat.com/show_bug.cgi?id=826677

Initial topology:  (single replication)
  1
  |
  2

Version-Release number of selected component (if applicable):
ipa-server-3.3.1-1.el7.x86_64

How reproducible:
alweays

Steps to Reproduce:
#. on host 1
1. ipa-server-install 
2. ipa-replica-prepare --ip-address=<ip of host 2> host2
#. on host 2
3. ipa-replica-install <gpg-file>
#. on host 1
4. ipa-replica-manage disconnect $HOST1 $HOST2
# on host2:
5.  ipa-server-install --uninstall -U
# on host1:
5.  ipa-replica-prepare -p $ADMINPW --ip-address=$HOST2_IP $HOST2
# on host2:
6.  cd /dev/shm; sftp root@$HOST1:/var/lib/ipa/replica-info-$HOST2.gpg
7.  ipa-replica-install -U --setup-dns --forwarder=$DNSFORWARD -w $ADMINPW -p $ADMINPW /dev/shm/replica-info-$HOST2.gpg


Actual results:
[root@ipaqavme ~]# ipa host-del --updatedns ipaqavmf.testrelm.com
ipa: ERROR: invalid 'hostname': An IPA master host cannot be deleted or disabled
[root@ipaqavme ~]# ipa-replica-manage del ipaqavmf.testrelm.com --force
Connection to 'ipaqavmf.testrelm.com' failed: 
Forcing removal of ipaqavmf.testrelm.com
Skipping calculation to determine if one or more masters would be orphaned.
No RUV records found.
[root@ipaqavme ~]# ipa host-del --updatedns ipaqavmf.testrelm.com
ipa: ERROR: invalid 'hostname': An IPA master host cannot be deleted or disabled


Additional info:

I am able to work-around this problem by following the instructions noted in comment 15 from BZ 826677, ith this command:
[root@ipaqavme ~]# ldapdelete -r -x -D "cn=Directory Manager" -W 'cn=ipaqavmf.testrelm.com,cn=masters,cn=ipa,cn=etc,dc=testrelm,dc=com'
Enter LDAP Password: 

[root@ipaqavme ~]# ldapsearch -x -LLL -D "cn=Directory Manager" -W -b 'cn=ipaqavmf.testrelm.com,cn=masters,cn=ipa,cn=etc,dc=testrelm,dc=com'
Enter LDAP Password: 
No such object (32)
Matched DN: cn=masters,cn=ipa,cn=etc,dc=testrelm,dc=com
Comment 2 Rob Crittenden 2013-09-04 19:28:03 EDT
This should be addressed by https://bugzilla.redhat.com/show_bug.cgi?id=1001662

With that fix, passing the --cleanup option to ipa-replica-manage delete may be all that is needed to clean things up.
Comment 3 Michael Gregg 2013-09-04 21:42:25 EDT
I am still getting this error, do I not have the updated bits? I am currently on ipa-server-3.3.1-1.el7.x86_64:

[root@tigger ipa-dns-multi]# ipa-replica-manage del ipaqa64vmg.testrelm2.com --cleanup
Connection to 'ipaqa64vmg.testrelm2.com' failed: 
Forcing removal of ipaqa64vmg.testrelm2.com
Skipping calculation to determine if one or more masters would be orphaned.
No RUV records found.

[root@tigger ipa-dns-multi]# ipa host-del --updatedns ipaqa64vmg.testrelm2.com
ipa: ERROR: invalid 'hostname': An IPA master host cannot be deleted or disabled
Comment 4 Martin Kosek 2013-09-05 05:00:18 EDT
Previous RHEL build did not contain the patch - I produced a new one (ipa-3.3.1-2.el7) which should fix this issue.

Closing as duplicate for Bug 1001662, please write a note there if the fix does not work.

*** This bug has been marked as a duplicate of bug 1001662 ***

Note You need to log in before you can comment on or make changes to this bug.