This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1004561 - Abort when clicking on Printer Setting, Connector combo box
Abort when clicking on Printer Setting, Connector combo box
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: RepetierHost (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miro Hrončok
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 20:03 EDT by Tom Horsley
Modified: 2013-09-22 20:49 EDT (History)
1 user (show)

See Also:
Fixed In Version: RepetierHost-0.90D-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 21:57:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2013-09-04 20:03:36 EDT
Description of problem:
Bring up the Printer Setting dialog.

Click the arrow on the Connector combo box (which has Serial Connection showing as the default value).

Program go boom:

System.InvalidCastException: Cannot cast from source type to destination type.
  at (wrapper managed-to-native) object:__icall_wrapper_mono_object_castclass (object,intptr)
  at System.Reflection.MonoProperty.GetterAdapterFrame[SerialConnector,String] (System.Reflection.Getter`2 getter, System.Object obj) [0x00000] in <filename unknown>:0 
  at System.Reflection.MonoProperty.GetValue (System.Object obj, System.Object[] index) [0x00000] in <filename unknown>:0 
  at System.ComponentModel.ReflectionPropertyDescriptor.GetValue (System.Object component) [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.ListControl.FilterItemOnProperty (System.Object item, System.String field) [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.ListControl.GetItemText (System.Object item) [0x00000] in <filename unknown>:0 
  at (wrapper remoting-invoke-with-check) System.Windows.Forms.ListControl:GetItemText (object)
  at System.Windows.Forms.ThemeWin32Classic.DrawComboBoxItem (System.Windows.Forms.ComboBox ctrl, System.Windows.Forms.DrawItemEventArgs e) [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.ComboBox.HandleDrawItem (System.Windows.Forms.DrawItemEventArgs e) [0x00000] in <filename unknown>:0 
  at (wrapper remoting-invoke-with-check) System.Windows.Forms.ComboBox:HandleDrawItem (System.Windows.Forms.DrawItemEventArgs)
  at System.Windows.Forms.ComboBox+ComboListBox.Draw (Rectangle clip, System.Drawing.Graphics dc) [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.ComboBox+ComboListBox.OnPaintInternal (System.Windows.Forms.PaintEventArgs pevent) [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.Control.WmPaint (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.Control.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.ComboBox+ComboListBox.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.Control+ControlWindowTarget.OnMessage (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.Control+ControlNativeWindow.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.NativeWindow.WndProc (IntPtr hWnd, Msg msg, IntPtr wParam, IntPtr lParam) [0x00000] in <filename unknown>:0 
System.ObjectDisposedException: The object was used after being disposed.
  at System.Windows.Forms.Control.CreateHandle () [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.ComboBox.CreateHandle () [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.Control.get_Handle () [0x00000] in <filename unknown>:0 
  at (wrapper remoting-invoke-with-check) System.Windows.Forms.Control:get_Handle ()
  at System.Windows.Forms.Control.set_Capture (Boolean value) [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.ComboBox.OnMouseDownCB (System.Object sender, System.Windows.Forms.MouseEventArgs e) [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.Control.OnMouseDown (System.Windows.Forms.MouseEventArgs e) [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.Control.WmLButtonDown (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.Control.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.ComboBox.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.Control+ControlWindowTarget.OnMessage (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.Control+ControlNativeWindow.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.NativeWindow.WndProc (IntPtr hWnd, Msg msg, IntPtr wParam, IntPtr lParam) [0x00000] in <filename unknown>:0 



Version-Release number of selected component (if applicable):
RepetierHost-0.90C-1.fc19.noarch

How reproducible:
Every time

Steps to Reproduce:
1.see above
2.
3.

Actual results:
boom

Expected results:
not sure, never been able to see the choices :-).

Additional info:
Comment 1 Miro Hrončok 2013-09-04 20:17:43 EDT
Well, I can reproduce this.

Before I try it myself, was this present in previous version or you don't know that? As from "never been able to see the choices" I assume you haven't tested, right?
Comment 2 Tom Horsley 2013-09-04 20:44:00 EDT
Right. I just got my printer today and was downloading lots of stuff for the very first time. I didn't try the 0.84 version in the fedora repos, I went right for updates-testing :-).
Comment 3 Miro Hrončok 2013-09-04 23:36:12 EDT
This large commit fixes it [0] but introduces some necessary changes in spec. I'll update it soon.
Comment 5 Miro Hrončok 2013-09-06 11:33:59 EDT
I've pushed the fix, but for some weird reason it fails to build in Koji due to some Mono crap. Stay tuned.
Comment 6 Fedora Update System 2013-09-09 08:06:48 EDT
RepetierHost-0.90D-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/RepetierHost-0.90D-1.fc19
Comment 7 Fedora Update System 2013-09-09 08:08:26 EDT
RepetierHost-0.90D-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/RepetierHost-0.90D-1.fc18
Comment 8 Fedora Update System 2013-09-09 08:10:46 EDT
RepetierHost-0.90D-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/RepetierHost-0.90D-1.fc20
Comment 9 Fedora Update System 2013-09-09 12:19:48 EDT
Package RepetierHost-0.90D-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing RepetierHost-0.90D-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16141/RepetierHost-0.90D-1.fc20
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-09-10 21:57:45 EDT
RepetierHost-0.90D-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-09-18 08:58:58 EDT
RepetierHost-0.90D-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-09-22 20:49:37 EDT
RepetierHost-0.90D-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.