Bug 1004623 - References to old collection names and content_unit_count needs to be updated in API docs
References to old collection names and content_unit_count needs to be updated...
Status: CLOSED UPSTREAM
Product: Pulp
Classification: Community
Component: documentation (Show other bugs)
Master
Unspecified Unspecified
medium Severity low
: ---
: 2.6.0
Assigned To: Ina Panova
Preethi Thomas
: Triaged
: 767635 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 00:51 EDT by Sayli Karmarkar
Modified: 2015-03-22 21:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-28 16:58:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 367 None None None Never

  None (edit)
Description Sayli Karmarkar 2013-09-05 00:51:03 EDT
Content_unit_count is now a dictionary and is renamed to content_unit_counts. It should be updated in the examples of our rest API docs.

$ grep -r "content_unit_count" rest-api/*
rest-api/repo/retrieval.rst:  "content_unit_count": 0,
rest-api/repo/retrieval.rst:    "content_unit_count": 0,
rest-api/repo/retrieval.rst:    "content_unit_count": 0,
rest-api/repo/retrieval.rst:    "content_unit_count": 0,
rest-api/repo/cud.rst:  "content_unit_counts": {},
rest-api/repo/cud.rst:  "content_unit_counts": {},


There are also a lot of references to old collection names "gc_repo_importers", "gc_repos" etc.

$ grep -r "gc_" rest-api/*
rest-api/consumer/retrieval.rst:   "_ns": "gc_consumers",
rest-api/consumer/retrieval.rst:    "_ns": "gc_consumers",
rest-api/consumer/retrieval.rst:    "_ns": "gc_consumers",
rest-api/consumer/retrieval.rst:    "_ns": "gc_consumers",
rest-api/consumer/retrieval.rst:    "_ns": "gc_consumers",
rest-api/consumer/retrieval.rst:    "_ns": "gc_consumers",
rest-api/consumer/retrieval.rst:    "_ns": "gc_consumers",
rest-api/consumer/history.rst:    "_ns": "gc_consumer_history", 
rest-api/consumer/history.rst:    "_ns": "gc_consumer_history", 
rest-api/consumer/cud.rst:  "_ns": "gc_consumers",
rest-api/consumer/cud.rst:  "_ns": "gc_consumers",
rest-api/repo/retrieval.rst:      "_ns": "gc_repo_distributors",
rest-api/repo/retrieval.rst:      "_ns": "gc_repo_importers",
rest-api/repo/retrieval.rst:        "_ns": "gc_repo_distributors",
rest-api/repo/retrieval.rst:        "_ns": "gc_repo_importers",
rest-api/repo/retrieval.rst:        "_ns": "gc_repo_distributors",
rest-api/repo/retrieval.rst:        "_ns": "gc_repo_importers",
rest-api/repo/retrieval.rst:        "_ns": "gc_repo_distributors",
rest-api/repo/retrieval.rst:        "_ns": "gc_repo_importers",
rest-api/repo/retrieval.rst:    "_ns": "gc_repo_importers",
rest-api/repo/retrieval.rst:    "_ns": "gc_repo_distributors",
rest-api/repo/cud.rst:  "_ns": "gc_repo_importers",
rest-api/repo/cud.rst:  "_ns": "gc_repo_distributors",
Comment 1 Chris Duryee 2014-11-11 20:28:58 EST
This is still outstanding as of Pulp 2.4.3.
Comment 2 Chris Duryee 2014-11-11 20:58:11 EST
*** Bug 767635 has been marked as a duplicate of this bug. ***
Comment 3 Ina Panova 2014-11-18 10:00:34 EST
https://github.com/pulp/pulp/pull/1315
Comment 4 Chris Duryee 2014-11-19 18:31:04 EST
PR has been merged to 2.6-dev and master, setting state to MODIFIED.
Comment 5 Chris Duryee 2014-12-23 15:53:00 EST
fixed in pulp 2.6.0-0.2.beta
Comment 6 Preethi Thomas 2015-01-28 12:41:50 EST
verified
http://pulp.readthedocs.org/en/latest/
Comment 7 Brian Bouterse 2015-02-28 16:58:09 EST
Moved to https://pulp.plan.io/issues/367

Note You need to log in before you can comment on or make changes to this bug.