Bug 1004635 - Duplicate signatures when using "Edit as new mail" or forwarding
Duplicate signatures when using "Edit as new mail" or forwarding
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 02:23 EDT by Ankur Sinha (FranciscoD)
Modified: 2013-09-05 02:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 02:58:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 687914 None None None Never

  None (edit)
Description Ankur Sinha (FranciscoD) 2013-09-05 02:23:49 EDT
Description of problem:
I sent out a mail. It went with one of my signatures "A". When I want to send the same mail to someone else, the mail will have the signature from the first sending, and include another signature. Therefore, the mail becomes

text

..

A

A


Version-Release number of selected component (if applicable):
evolution-3.8.5-2.fc19.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Send mail with signature
2.Resend mail to another receiver or forward it 
3.

Actual results:
Signature duplicated

Expected results:
Signature should not be duplicated


Additional info:
I'm not sure if this is a RFE or a bugreport really. 

I found something similar here:
https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/1055497

This says it was fixed in 3.6.2, but I still see it. 

Is it possible to please detect that a signature is already present and another one does not need to be added?

I haven't filed it upstream yet since I'd like at least one more person to confirm the bug.
Comment 1 Milan Crha 2013-09-05 02:58:23 EDT
Thanks for a bug report. You are right, there is lost an information about the signature, thus evolution doesn't recognize it, thus it adds a new, which results in duplicated signatures in an email. This is already filled upstream as [1]. Please see it for any further updates.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=687914

Note You need to log in before you can comment on or make changes to this bug.