This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1004642 - KPI initialization exceptions on server startup about jBPM tables not found
KPI initialization exceptions on server startup about jBPM tables not found
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: BAM (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER4
: 6.0.0
Assigned To: David Gutierrez
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 02:40 EDT by Jan Hrcek
Modified: 2014-08-06 16:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:10:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jhrcek: needinfo+


Attachments (Terms of Use)
server.log with exceptions (123.25 KB, text/x-log)
2013-09-05 02:40 EDT, Jan Hrcek
no flags Details

  None (edit)
Description Jan Hrcek 2013-09-05 02:40:11 EDT
Created attachment 793996 [details]
server.log with exceptions

Description of problem:
There is an "order of deployment" issue when dashbuilder.war and business-central.war are deployed together. Since some dashbuilder KPIs depend on existence of tables created by business-central it sometimes happens, that there is a lot of exceptions from dashbuilder complaining about nonexistent tables - see server.log attached.

example:
: org.h2.jdbc.JdbcSQLException: Table "PROCESSINSTANCELOG" not found; SQL statement:


Version-Release number of selected component (if applicable):
BPMS 6.0.0 ER2 deployed on EAP 6.1.0, with default H2 in-memory database as datasource.

How reproducible:
This problem happens only occasionaly, in about 10% of cases

Steps to Reproduce:
1. start eap with BPMS (dashbuilder + business central) deployed
2. wait for exceptions in EAP console.

Actual results:
Dashbuilder throws a lot of exceptions when initializing KPIs that depend on data from tables created by business-central.

Expected results:
In ideal case dashbuilder should be deployed AFTER business central deployment is finished. Would that be possible to guarantee order of deployment?

Additional info:
see server.log - search for 08:25:13,399

In server log we can clearly see that the required tables are created AFTER dashbuilder deployment is finished.
Comment 1 David Gutierrez 2013-09-05 07:28:27 EDT
The jBPM Dashboard is dependent on the jBPM Engine so it's always mandatory to deploy first jBPM  in any of its different flavours: jBPM Console, Kie-wb, ...

That prerequisite is highlighted here: https://github.com/droolsjbpm/jbpm-dashboard/blob/master/jbpm-dashboard-distributions/src/main/tomcat7/README.md#prerequisites 

We should not expect any issues if we apply the right deployment order.

Are we still having issues despite of that?
Comment 2 Jan Hrcek 2013-09-05 07:47:34 EDT
Hello Ryan,

can we somehow guarrantee the following order of deployment for the 2 applications that make up BPMS product?


1) business-central.war
2) dashbuilder.war

From my point of view it seems, that deployment on EAP 6.1.0 runs in parralel which occasionaly leads to dashbuilder throwing above mentioned exceptions
Comment 7 Jan Hrcek 2013-10-16 05:49:42 EDT
Verified with BPMS 6.0.0 ER4

Note You need to log in before you can comment on or make changes to this bug.