Bug 100465 - after up2date update and restart --nosig is not in effect
Summary: after up2date update and restart --nosig is not in effect
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: beta1
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-22 18:36 UTC by Ulrich Drepper
Modified: 2007-04-18 16:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-06 23:58:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ulrich Drepper 2003-07-22 18:36:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030715
Mozilla Firebird/0.6

Description of problem:
I ran

  up2date --nosig

with a up2date version 3.1.35-something when version 3.1.46-2 was available in
the channel.  I got helpfully asked whether I first want to reinstall up2date. 
I did this and up2date restarted fine.

But during the download the popups telling me about unknown keys appear.  They
should have been avoided since the initial up2date invocation used --nosig and
this option should have been passed to the new invocation.

Version-Release number of selected component (if applicable):
up2date-3.1.46-2

How reproducible:
Didn't try

Steps to Reproduce:
1.install old  up2date
2.update from channel with binaries using unknown key; start up2date
with --nosig parameter
3.agree to install up2date and restart
4.continue installing
    

Actual Results:  Popups asking about keys appear.

Expected Results:  Initial --nosig should be respected.

Additional info:

Comment 1 Adrian Likins 2003-07-23 20:56:32 UTC
I belive this should be fixed in later versions (argv list was getting
wiped by the gui). It should now be preserved between invocations.

Comment 2 Ulrich Drepper 2003-10-06 23:58:53 UTC
Haven't seen the problem ever since.  Assumed to be fixed.


Note You need to log in before you can comment on or make changes to this bug.