Bug 1004683 - Can not start qemu when the identifier of device/driver is not started w/ letter
Can not start qemu when the identifier of device/driver is not started w/ letter
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 04:37 EDT by Qian Guo
Modified: 2013-09-10 06:06 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 05:06:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qian Guo 2013-09-05 04:37:26 EDT
Description of problem:
Can not boot guest when try to use file based monitor via chardev 

Version-Release number of selected component (if applicable):
# rpm -q qemu-kvm
qemu-kvm-1.5.3-2.el7.x86_64
# uname -r
3.10.0-15.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Try to boot guest w/  options "-chardev socket,id=111a,path=/tmp/monitor,server,nowait -mon chardev=111a,mode=readline "

cli like this:
# /usr/libexec/qemu-kvm -cpu Penryn -enable-kvm -m 4096 -smp 4,sockets=1,cores=4,threads=1 -name rhel7base  -drive file=/mnt/rhel7cp1.qcow2_v3,if=none,id=drive-virtio-disk0,format=qcow2,werror=stop,rerror=stop,aio=native -device virtio-blk-pci,drive=drive-virtio-disk0,id=virtio-disk0 -boot menu=on -monitor stdio -netdev tap,id=hostnet0,ifname=guest1,script=/etc/ovs-ifup,downscript=/etc/ovs-ifdown,vhost=on,queues=4 -device virtio-net,netdev=hostnet0,mac=54:52:1b:35:3c:16,id=test,mq=on,vectors=9 -nodefaults -nodefconfig -spice port=5930,seamless-migration=on,disable-ticketing -vga qxl -global qxl-vga.vram_size=67108864   -device virtio-balloon-pci,id=balloon1 -qmp tcp:0:4446,server,nowait  -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -serial unix:/tmp/qiguo,server,nowait -chardev socket,id=111a,path=/tmp/monitor,server,nowait -mon chardev=111a,mode=readline 
2.
3.

Actual results:
Can not launch qemu-kvm, prompt:
qemu-kvm: -chardev socket,id=111a,path=/tmp/monitor,server,nowait: Parameter 'id' expects an identifier


Expected results:
Can boot w/ no error.

Additional info:
Comment 2 Gerd Hoffmann 2013-09-10 05:06:57 EDT
Identifiers must start with a letter, so '111a' isn't considered an valid id.
Comment 3 Qian Guo 2013-09-10 05:16:53 EDT
(In reply to Gerd Hoffmann from comment #2)
> Identifiers must start with a letter, so '111a' isn't considered an valid id.

Hi, Gerd

I test this in a rhel6.5/rhel6.4 host, the 111a can be used, so I filed this bug.
Can we unify the rule for these 2 products?
If identifiers must start with a letter in both rhel6 and rhel7 hosts, we should file a bug against rhel6.

So do we need file a bug against rhel6 or reopen this bug for rhel7?


Thanks!
Qian Guo
Comment 4 Gerd Hoffmann 2013-09-10 05:23:57 EDT
qemu got better at checking parameters over time, so rhel7 can be more strict than rhel6.  So, yes, rhel6 should refuse to accept those too in theory.  I doubt it is worth bothering though.
Comment 5 Qian Guo 2013-09-10 06:06:08 EDT
(In reply to Gerd Hoffmann from comment #4)
> qemu got better at checking parameters over time, so rhel7 can be more
> strict than rhel6.  So, yes, rhel6 should refuse to accept those too in
> theory.  I doubt it is worth bothering though.
Hi, Gerd

Thank you for your reply, and I found all virtual devices/drivers must start w/ letter in rhel7 and need not in rhel6, so I will file a low low bug in rhel6 to track.

Since this is just a bug about the rule of identifiers, I will change the bug summary.

Thank you
Qian Guo.

Note You need to log in before you can comment on or make changes to this bug.