Bug 1004691 - Bulk Signal causes errors
Bulk Signal causes errors
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ER4
: 6.0.0
Assigned To: Mauricio Salatino
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 04:58 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:08:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error for process with user task (31.94 KB, text/x-log)
2013-09-05 04:58 EDT, Zuzana Krejčová
no flags Details
errors when process ends after signal (10.77 KB, application/zip)
2013-09-05 05:00 EDT, Zuzana Krejčová
no flags Details
signal process with user task (10.01 KB, application/xml)
2013-09-05 05:16 EDT, Zuzana Krejčová
no flags Details
signal process with sys.out script (8.63 KB, application/xml)
2013-09-05 05:17 EDT, Zuzana Krejčová
no flags Details

  None (edit)
Description Zuzana Krejčová 2013-09-05 04:58:32 EDT
Created attachment 794121 [details]
error for process with user task

Description of problem:
I have 2 processes, one waits for a signal, then prints a message to System.out and ends, the other waits for a signal, then continues with a user task:
(A) Start -> Signal -> Script -> End
(B) Start -> Signal -> User Task -> End

In both cases, Bulk Signal on 2 instances causes problems. One of the instances might not act on the signal. In case (B), the exception seems to be always the same, in case (A), it varies.

If the process doesn't end (almost immediately) or continue with a user task after the signal node, it seems to be okay. Same if the signal simply doesn't work with the instance (wrong signal ref., no signal node).

See attached stack traces from server log.


Version-Release number of selected component (if applicable):
BPMS 6.0 ER2
Comment 1 Zuzana Krejčová 2013-09-05 05:00:14 EDT
Created attachment 794124 [details]
errors when process ends after signal
Comment 2 Mauricio Salatino 2013-09-05 05:05:29 EDT
Zuzana, can you please attach the reproducer processes? Both of them please.
Comment 3 Zuzana Krejčová 2013-09-05 05:16:27 EDT
Created attachment 794133 [details]
signal process with user task
Comment 4 Zuzana Krejčová 2013-09-05 05:17:19 EDT
Created attachment 794134 [details]
signal process with sys.out script
Comment 5 Mauricio Salatino 2013-09-05 06:21:16 EDT
Zuzana, just for me to reproduce the exact same issue that you are having what are you filling in the Signal Name and Signal Data fields?
Comment 6 Zuzana Krejčová 2013-09-05 08:09:23 EDT
(In reply to Mauricio Salatino from comment #5)
> Zuzana, just for me to reproduce the exact same issue that you are having
> what are you filling in the Signal Name and Signal Data fields?

The user task process uses 'qwe' as the signal ref (signal name).
The script process uses 'someSignal' as the signal ref.

In both cases I leave the signal data blank.
Comment 7 Mauricio Salatino 2013-09-05 09:37:50 EDT
fixed in master http://github.com/droolsjbpm/jbpm-console-ng/compare/5f86b28...40d3619
Comment 11 Jan Hrcek 2013-10-18 02:05:16 EDT
Ok, verified with BPMS 6.0.0 ER4

Note You need to log in before you can comment on or make changes to this bug.