Bug 1004722 - [abrt] ibus-kkc-1.5.16-1.fc19: g_realloc: Process /usr/libexec/ibus-engine-kkc was killed by signal 5 (SIGTRAP)
[abrt] ibus-kkc-1.5.16-1.fc19: g_realloc: Process /usr/libexec/ibus-engine-kk...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-kkc (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daiki Ueno
Fedora Extras Quality Assurance
abrt_hash:579df7cb549d4688ce64fa7949e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 06:58 EDT by fedoraxx.bugzilla.redhat
Modified: 2013-09-24 18:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: ibus-kkc-1.5.18-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-22 20:17:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (37.92 KB, text/plain)
2013-09-05 06:58 EDT, fedoraxx.bugzilla.redhat
no flags Details
File: cgroup (140 bytes, text/plain)
2013-09-05 06:58 EDT, fedoraxx.bugzilla.redhat
no flags Details
File: core_backtrace (15.33 KB, text/plain)
2013-09-05 06:58 EDT, fedoraxx.bugzilla.redhat
no flags Details
File: dso_list (8.55 KB, text/plain)
2013-09-05 06:58 EDT, fedoraxx.bugzilla.redhat
no flags Details
File: environ (1.02 KB, text/plain)
2013-09-05 06:58 EDT, fedoraxx.bugzilla.redhat
no flags Details
File: limits (1.29 KB, text/plain)
2013-09-05 06:58 EDT, fedoraxx.bugzilla.redhat
no flags Details
File: maps (123.06 KB, text/plain)
2013-09-05 06:59 EDT, fedoraxx.bugzilla.redhat
no flags Details
File: open_fds (22.89 KB, text/plain)
2013-09-05 06:59 EDT, fedoraxx.bugzilla.redhat
no flags Details
File: proc_pid_status (941 bytes, text/plain)
2013-09-05 06:59 EDT, fedoraxx.bugzilla.redhat
no flags Details
File: var_log_messages (65 bytes, application/octet-stream)
2013-09-05 06:59 EDT, fedoraxx.bugzilla.redhat
no flags Details

  None (edit)
Description fedoraxx.bugzilla.redhat 2013-09-05 06:58:34 EDT
Version-Release number of selected component:
ibus-kkc-1.5.16-1.fc19

Additional info:
reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/libexec/ibus-engine-kkc --ibus
crash_function: g_realloc
executable:     /usr/libexec/ibus-engine-kkc
kernel:         3.10.9-200.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 g_realloc at gmem.c:229
 #3 g_array_maybe_expand at garray.c:785
 #4 g_array_set_size at garray.c:561
 #5 g_byte_array_set_size at garray.c:1702
 #6 g_file_load_contents at gfile.c:6498
 #7 kkc_loaded_index_file_construct at utils.c:3195
 #8 kkc_sorted_trigram_language_model_real_parse at sorted-trigram-language-model.c:545
 #9 kkc_language_model_real_init at language-model.c:751
 #10 g_initable_new_valist at ginitable.c:231
 #11 g_initable_new at ginitable.c:149
Comment 1 fedoraxx.bugzilla.redhat 2013-09-05 06:58:39 EDT
Created attachment 794184 [details]
File: backtrace
Comment 2 fedoraxx.bugzilla.redhat 2013-09-05 06:58:42 EDT
Created attachment 794185 [details]
File: cgroup
Comment 3 fedoraxx.bugzilla.redhat 2013-09-05 06:58:45 EDT
Created attachment 794186 [details]
File: core_backtrace
Comment 4 fedoraxx.bugzilla.redhat 2013-09-05 06:58:50 EDT
Created attachment 794187 [details]
File: dso_list
Comment 5 fedoraxx.bugzilla.redhat 2013-09-05 06:58:53 EDT
Created attachment 794189 [details]
File: environ
Comment 6 fedoraxx.bugzilla.redhat 2013-09-05 06:58:57 EDT
Created attachment 794190 [details]
File: limits
Comment 7 fedoraxx.bugzilla.redhat 2013-09-05 06:59:09 EDT
Created attachment 794191 [details]
File: maps
Comment 8 fedoraxx.bugzilla.redhat 2013-09-05 06:59:12 EDT
Created attachment 794192 [details]
File: open_fds
Comment 9 fedoraxx.bugzilla.redhat 2013-09-05 06:59:16 EDT
Created attachment 794193 [details]
File: proc_pid_status
Comment 10 fedoraxx.bugzilla.redhat 2013-09-05 06:59:19 EDT
Created attachment 794194 [details]
File: var_log_messages
Comment 11 Daiki Ueno 2013-09-10 04:06:00 EDT
Could you tell us how did you hit on the problem?

From the backtrace, the process failed to allocate only 16MB of memory:

  gmem.c:230: failed to allocate 16777216 bytes

So I don't think this is the root cause.  However, in the same log, it seems too many engine processes had been created:

  "/org/freedesktop/IBus/Engine/231"
Comment 12 Fedora Update System 2013-09-10 05:53:45 EDT
ibus-kkc-1.5.17-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-kkc-1.5.17-1.fc19
Comment 13 Fedora Update System 2013-09-10 05:53:54 EDT
ibus-kkc-1.5.17-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ibus-kkc-1.5.17-1.fc20
Comment 14 Fedora Update System 2013-09-10 05:54:06 EDT
ibus-kkc-1.5.17-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-kkc-1.5.17-1.fc18
Comment 15 Daiki Ueno 2013-09-10 05:55:13 EDT
Anyway, I added a workaround.
Comment 16 Fedora Update System 2013-09-13 04:35:51 EDT
ibus-kkc-1.5.18-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ibus-kkc-1.5.18-1.fc20
Comment 17 Fedora Update System 2013-09-13 04:36:06 EDT
ibus-kkc-1.5.18-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-kkc-1.5.18-1.fc19
Comment 18 Fedora Update System 2013-09-13 13:27:36 EDT
Package ibus-kkc-1.5.18-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-kkc-1.5.18-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16627/ibus-kkc-1.5.18-1.fc20
then log in and leave karma (feedback).
Comment 19 Fedora Update System 2013-09-22 20:17:33 EDT
ibus-kkc-1.5.18-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2013-09-24 18:51:27 EDT
ibus-kkc-1.5.18-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.