Bug 1004725 - [origin_ui_58] The suggestion did not show clearly need to delete node from which district
[origin_ui_58] The suggestion did not show clearly need to delete node from w...
Status: CLOSED WONTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
All All
low Severity medium
: ---
: ---
Assigned To: Luke Meyer
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 07:06 EDT by zhaozhanqi
Modified: 2015-05-14 21:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-11 14:37:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhaozhanqi 2013-09-05 07:06:19 EDT
Description of problem:
when one district available active gears are greater than 'GEAR_DOWN_THRESHOLD', the suggestion will show 'Excess capacity in gear profile small', but it did not say to need to remove node from which one district. 

Version-Release number of selected component (if applicable):
fork_ami_origin_ui_81_821

How reproducible:
always

Steps to Reproduce:
1. create one small district and add two nodes to it
2. set 'GEAR_DOWN_THRESHOLD=2000, small: 170'
3. login on admin-console-->suggestions

Actual results:

Excess capacity in gear profile small
Remove 1 node to reclaim excess capacity.

You currently have 179 active gears available, which exceeds the configured GEAR_DOWN_THRESHOLD of 170. The maximum number of active gears for nodes in this gear profile is 90, so removing 1 node will bring the available active gears below the threshold.

At this time, specifying which node to remove is difficult to automate robustly. Generally, it is a good idea to remove nodes that are not districted, nodes that are deactivated in their districts, and nodes that have the fewest gears to move.

Expected results:

should point out: need to remove node from which one distirct.

Additional info:
Comment 1 Luke Meyer 2013-09-05 09:06:02 EDT
You're right, that would be ideal. I didn't implement this yet, because the complexity didn't seem to be warranted for such an uncommon case. I'll keep this bug around to remind me, but it's just not a high priority.
Comment 3 Luke Meyer 2014-07-11 14:37:24 EDT
Realistically this is not enough of a priority to fix before 3.0, at which point the admin console will receive a radical makeover anyway.

Note You need to log in before you can comment on or make changes to this bug.