This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1004737 - SELinux is preventing /usr/lib/polkit-1/polkitd from using the 'net_bind_service' capabilities.
SELinux is preventing /usr/lib/polkit-1/polkitd from using the 'net_bind_serv...
Status: CLOSED DUPLICATE of bug 997142
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6513657dee1e10ed9ff3dd6aab7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 07:32 EDT by Marco Nolden
Modified: 2013-09-05 11:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 11:49:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marco Nolden 2013-09-05 07:32:20 EDT
Description of problem:
1. Logged in a i3 + GNOME session.

2. i3 does not start

3. manually started i3 from a console:

export DISPLAY=:0.0
i3
SELinux is preventing /usr/lib/polkit-1/polkitd from using the 'net_bind_service' capabilities.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that polkitd should have the net_bind_service capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep polkitd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:policykit_t:s0
Target Context                system_u:system_r:policykit_t:s0
Target Objects                 [ capability ]
Source                        polkitd
Source Path                   /usr/lib/polkit-1/polkitd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           polkit-0.111-2.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-73.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.10.9-200.fc19.x86_64 #1 SMP Wed
                              Aug 21 19:27:58 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-08-29 08:49:25 CEST
Last Seen                     2013-08-29 08:49:25 CEST
Local ID                      3b857f72-1e4c-4453-a3fb-a038241a8af6

Raw Audit Messages
type=AVC msg=audit(1377758965.386:1289): avc:  denied  { net_bind_service } for  pid=3427 comm="polkitd" capability=10  scontext=system_u:system_r:policykit_t:s0 tcontext=system_u:system_r:policykit_t:s0 tclass=capability


type=SYSCALL msg=audit(1377758965.386:1289): arch=x86_64 syscall=bind success=yes exit=0 a0=4 a1=7fff1bc757e0 a2=10 a3=7 items=0 ppid=1 pid=3427 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=polkitd exe=/usr/lib/polkit-1/polkitd subj=system_u:system_r:policykit_t:s0 key=(null)

Hash: polkitd,policykit_t,policykit_t,capability,net_bind_service

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.10-200.fc19.x86_64
type:           libreport
Comment 1 Marco Nolden 2013-09-05 07:33:18 EDT
Description of problem:
Description of problem:
1. Logged in a i3 + GNOME session.

2. i3 does not start

3. manually started i3 from a console:

export DISPLAY=:0.0
i3

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.10-200.fc19.x86_64
type:           libreport
Comment 2 Daniel Walsh 2013-09-05 09:23:54 EDT
Are you running with NIS?
Comment 3 Marco Nolden 2013-09-05 11:12:29 EDT
(In reply to Daniel Walsh from comment #2)
> Are you running with NIS?

Yes, NIS
Comment 4 Daniel Walsh 2013-09-05 11:49:46 EDT

*** This bug has been marked as a duplicate of bug 997142 ***

Note You need to log in before you can comment on or make changes to this bug.