Bug 1004743 - XSAVE migration format not compatible between RHEL6 and RHEL7
XSAVE migration format not compatible between RHEL6 and RHEL7
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
: Reopened
Depends On: 1016736
Blocks: 889670 915399
  Show dependency treegraph
 
Reported: 2013-09-05 07:50 EDT by Paolo Bonzini
Modified: 2014-06-17 23:35 EDT (History)
9 users (show)

See Also:
Fixed In Version: qemu-kvm-1.5.3-11.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1004773 1016736 (view as bug list)
Environment:
Last Closed: 2014-06-13 05:36:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paolo Bonzini 2013-09-05 07:50:57 EDT
VMState format for XSAVE data is incompatible between RHEL6 and RHEL7.

RHEL6 used a subsection, RHEL7 bumped the version number.  As a result, SandyBridge, Haswell, Opteron_G4 and Opteron_G5 CPU models cannot be migrated to RHEL7.
Comment 2 Paolo Bonzini 2013-09-06 11:19:04 EDT
*** Bug 997702 has been marked as a duplicate of this bug. ***
Comment 3 huiqingding 2013-09-10 22:04:29 EDT
I duplicate this bug to bug 997702, as talked to Paolo:

https://bugzilla.redhat.com/show_bug.cgi?id=997702#c11

*** This bug has been marked as a duplicate of bug 997702 ***
Comment 4 Paolo Bonzini 2013-10-10 05:44:08 EDT
This affects all models, not just those listed.
Comment 5 Eduardo Habkost 2013-10-17 10:44:00 EDT
(In reply to Paolo Bonzini from comment #4)
> This affects all models, not just those listed.

Does it? If xsave is not enabled on CPUID, the xsave section will be skipped.
Comment 7 Paolo Bonzini 2013-10-18 03:20:48 EDT
See bug 1016736 comment 4.  But it is possible that for non-XSAVE models the problem is the ACPI one.
Comment 8 Miroslav Rezanina 2013-10-31 03:56:21 EDT
Fix included in qemu-kvm-1.5.3-11.el7
Comment 10 FuXiangChun 2013-11-11 03:10:12 EST
Verify this bug with qemu-kvm-1.5.3-18.el7.x86_64.rpm

Testd four cpu model(include xsave flag)
1. Opteron_G5 2. Opteron_G4 3. Hasswell 4. SandyBridge

Tested seven cpu models(not include xsave flag)

AMD cpu model: Opteron_G1,Opteron_G2 and Opteron_G3
Intel cpu model:Westmere,Nehalem,Penryn and Conroe

All cpu model above works well when migrating from rhel6.5 to rhel7.0 host.


Base on this result above. This bug is fixed.
Comment 12 Ludek Smid 2014-06-13 05:36:33 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.