Bug 1004761 - Starting many process with human tasks via JMS ends in: Could not commit session: java.lang.NullPointerException
Starting many process with human tasks via JMS ends in: Could not commit sess...
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ER4
: 6.0.0
Assigned To: Marco Rietveld
Jiri Svitak
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 08:22 EDT by Jiri Svitak
Modified: 2016-09-20 01:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:07:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (27.19 KB, text/plain)
2013-09-05 08:22 EDT, Jiri Svitak
no flags Details
mysql-ds.xml (490 bytes, text/plain)
2013-09-05 08:23 EDT, Jiri Svitak
no flags Details

  None (edit)
Description Jiri Svitak 2013-09-05 08:22:40 EDT
Created attachment 794253 [details]
server.log

Starting many process with human tasks via JMS ends in: Could not commit session: java.lang.NullPointerException.

14:16:13,966 WARN  [org.drools.persistence.SingleSessionCommandService] (Thread-7 (HornetQ-client-global-threads-1162166649)) Could not commit session: java.lang.NullPointerException

To reproduce:
1.) Download BPMS 6 ER2 and merge it with JBoss EAP 6.1.
2.) Setup user guest, with password guest. Hint:
guest=b5d048a237bfd2874b6928e1f37ee15e
guest=kie-user,ADMIN
3.) Configure both business-central.war and dashbuilder.war to use MySQL database. Add mysql-connector-java-5.1.26-bin.jar and mysql-ds.xml to ${EAP_DIR}/standalone/deployments to deploy a MySQL datasource. Change DS name to java:jboss/datasources/mysqlDS and hibernate dialect to org.hibernate.dialect.MySQL5InnoDBDialect in dashbuilder.war/WEB-INF/jboss-web.xml and business-central.war/WEB-INF/classes/META-INF/persistence.xml.
4.) Add role kie-user to JMS configuration in standalone.xml, subsystem messaging -> security settings to enable guest user to send messages to JMS queues.
5.) Run it with
cd ${EAP_DIR}/bin
./standalone.sh
6.) Install PerfCake 1.0-SNAPSHOT
git clone https://github.com/PerfCake/PerfCake.git
cd PerfCake
git checkout devel
mvn clean install -DskipTests
7.) Run perf scenario, just two iterations are enough to break:
git clone git://git.app.eng.bos.redhat.com/jbossqe-process-flood.git
cd jbossqe-process-flood/bpms-6.x
./execute_scenario.sh -Dscenario=HumanTask_startProcess_JMS

My environment:
BPMS 6 ER2
JBoss EAP 6.1
MySQL 5.5.32
mysql-connector-java-5.1.26-bin.jar driver
Comment 1 Jiri Svitak 2013-09-05 08:23:49 EDT
Created attachment 794254 [details]
mysql-ds.xml

Setup your MySQL database according to this EAP data source configuration file.
Comment 2 Marco Rietveld 2013-09-05 08:29:45 EDT
This seems to be a duplicate of 999149: could you verify whether or not this is the case? In particular, see the server.log attached to BZ 999149.
Comment 6 Jiri Svitak 2013-10-15 11:29:49 EDT
Verified in BPMS 6 ER4.

Marco: Yes, this was probably a duplicate.

Note You need to log in before you can comment on or make changes to this bug.