Bug 1004762 - lsmd runs as initrc_t
lsmd runs as initrc_t
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.5
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks: 832330
  Show dependency treegraph
 
Reported: 2013-09-05 08:23 EDT by Milos Malik
Modified: 2014-10-14 03:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:57:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2013-09-05 08:23:39 EDT
Description of problem:
The libstoragemgmt package comes from EPEL, but the daemon is already confined in RHEL-7.

Version-Release number of selected component (if applicable):
libstoragemgmt-0.0.22-1.el6.i686
libstoragemgmt-ibm-v7k-plugin-0.0.22-1.el6.noarch
libstoragemgmt-netapp-plugin-0.0.22-1.el6.noarch
libstoragemgmt-nstor-plugin-0.0.22-1.el6.noarch
libstoragemgmt-python-0.0.22-1.el6.noarch
libstoragemgmt-smis-plugin-0.0.22-1.el6.noarch
libstoragemgmt-targetd-plugin-0.0.22-1.el6.noarch
selinux-policy-3.7.19-213.el6.noarch
selinux-policy-doc-3.7.19-213.el6.noarch
selinux-policy-minimum-3.7.19-213.el6.noarch
selinux-policy-mls-3.7.19-213.el6.noarch
selinux-policy-targeted-3.7.19-213.el6.noarch

How reproducible:
always

Steps to Reproduce:
# run_init service libstoragemgmtd status
Authenticating root.
Password: 
lsmd is stopped
# run_init service libstoragemgmtd start
Authenticating root.
Password: 
Starting lsmd daemon:                                      [  OK  ]
# run_init service libstoragemgmtd status
Authenticating root.
Password: 
lsmd (pid  5154) is running...
# ps -efZ | grep lsmd
system_u:system_r:initrc_t:s0   456       5154     1  0 14:20 ?        00:00:00 /usr/bin/lsmd
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 root 5170 3019  0 14:20 pts/0 00:00:00 grep lsmd
# 

Actual results:
 * lsmd runs as initrc_t

Expected results:
 * lsmd runs in its own SELinux domain
Comment 2 Lukas Vrabec 2014-04-29 11:35:45 EDT
Patch sent to Miroslav.
Comment 3 Lukas Vrabec 2014-05-02 08:21:43 EDT
commit 86c625bad7943a135c5861c68781b7312127ac0e
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Thu Apr 24 12:06:08 2014 +0200

    Added lsm policy
Comment 6 Lukas Vrabec 2014-06-23 13:04:41 EDT
sent patch
Comment 9 errata-xmlrpc 2014-10-14 03:57:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1568.html

Note You need to log in before you can comment on or make changes to this bug.