Bug 1004775 - virtual-manager fails to connect to qemu:///system due to polkit error
virtual-manager fails to connect to qemu:///system due to polkit error
Status: CLOSED DUPLICATE of bug 873799
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 09:03 EDT by Dennis Jacobfeuerborn
Modified: 2013-09-05 10:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 10:53:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Jacobfeuerborn 2013-09-05 09:03:24 EDT
When i start virt-manager and try to collect to localhost I get this:

=======================
Unable to connect to libvirt.

authentication failed: polkit: polkit\56retains_authorization_after_challenge=1
Authorization requires authentication but no agent is available.

Libvirt URI is: qemu:///system

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 1002, in _open_thread
    self.vmm = self._try_open()
  File "/usr/share/virt-manager/virtManager/connection.py", line 984, in _try_open
    flags)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 102, in openAuth
    if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirtError: authentication failed: polkit: polkit\56retains_authorization_after_challenge=1
Authorization requires authentication but no agent is available.
=======================

Using virsh on the command line seems to work fine.
Comment 1 Dennis Jacobfeuerborn 2013-09-05 09:22:38 EDT
I just checked on the machine itself and there it works. The issue only seems to occur when the virt-manager display is exported to another machine (i.e. "ssh -X" to the machine and then starting virt-manager).
Comment 2 Cole Robinson 2013-09-05 10:53:41 EDT

*** This bug has been marked as a duplicate of bug 873799 ***

Note You need to log in before you can comment on or make changes to this bug.