Bug 1004778 - Optaplanner score corruption caused by a bug in accumulate node
Optaplanner score corruption caused by a bug in accumulate node
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: BRE (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER4
: 6.0.0
Assigned To: Mario Fusco
Lukáš Petrovický
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 09:12 EDT by Mario Fusco
Modified: 2014-08-06 16:19 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:19:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to be applied to Optaplanner to reproduce the score corruption (30.05 KB, patch)
2013-09-05 09:12 EDT, Mario Fusco
no flags Details | Diff

  None (edit)
Description Mario Fusco 2013-09-05 09:12:00 EDT
Created attachment 794269 [details]
Patch to be applied to Optaplanner to reproduce the score corruption

Description of problem:

Optaplanner score corruption caused by a bug in accumulate node

Steps to Reproduce:

- Get last optaplanner master
- Apply patch in attachment
- Run VehicleRoutingApp.
- Load tmp.xml and solve

Actual results:

java.lang.IllegalStateException: Score corruption: the workingScore (-29hard/0soft) is not the uncorruptedScore (-23hard/0soft) after completedAction (10 => 16):

Expected results:

No score corruption
Comment 1 Mario Fusco 2013-09-05 09:18:22 EDT
Fixed by https://github.com/droolsjbpm/drools/commit/cad1eb3d5
Comment 6 Lukáš Petrovický 2013-10-17 02:54:20 EDT
Confirming that the fix had been applied. VERIFIED in ER4.

Note You need to log in before you can comment on or make changes to this bug.