Bug 10048 - mpg123 gives Can't resolve host name "unix"! warnings
mpg123 gives Can't resolve host name "unix"! warnings
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: esound (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-08 03:22 EST by w.w.wouts
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-24 15:32:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description w.w.wouts 2000-03-08 03:22:54 EST
Don't know why it does this. Here's some output:

High Performance MPEG 1.0/2.0/2.5 Audio Player for Layer 1, 2 and 3.
Version 0.59r (1999/Jun/15). Written and copyrights by Michael Hipp.
Uses code from various people. See 'README' for more!
THIS SOFTWARE COMES WITH ABSOLUTELY NO WARRANTY! USE AT YOUR OWN RISK!
Can't resolve host name "unix"!
Can't resolve host name "unix"!

I put "unix" in /etc/hosts as an alias for localhost which "fixed" it.
Comment 1 Bill Nottingham 2000-03-08 10:14:59 EST
esound is complaining about trying to contact a network host.
How do you have it set up?
Comment 2 Chris Seawood 2000-03-18 18:21:59 EST
I see the same problem.  Esound was never "set up" per se.  It was only
installed because mpg123 & xmms required it.  If I run 'esd &' beforehand,
mpg123 will complain that it can't open /dev/dsp.
Comment 3 jgotts 2000-05-02 00:15:59 EDT
This is a bug in libesd which has been discussed at length on the GNOME lists.
Basically, setting your DISPLAY environment variable to unix:0 used to be a
potential optimization over setting it to :0, but on most systems today it has
no effect.  At about the same time as libesd was being written, the rxvt
developers changed the default DISPLAY enviroment variable from :0 to unix:0 to
take advantage of this possible optimization.  The developers of libesd, unaware
of the meaning of unix:0, attempt to resolve the hostname unix when they should
instead crop off these four characters.  The warning is harmless and it probably
took me longer to write this comment than it will take some clever hacker to
correct the oversight.
Comment 4 Elliot Lee 2000-07-17 16:39:33 EDT
Special-casing the 'unix' hostname might have bad effects in the future - will
leave it as-is until someone comes up with a better reason to change.

Note You need to log in before you can comment on or make changes to this bug.