Bug 100482 - event processors need access to the session's flushAll() method
event processors need access to the session's flushAll() method
Status: CLOSED RAWHIDE
Product: Red Hat Web Application Framework
Classification: Retired
Component: persistence (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Archit Shah
Jon Orris
:
Depends On:
Blocks: 98546 100484
  Show dependency treegraph
 
Reported: 2003-07-22 16:26 EDT by Vadim Nasardinov
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-24 16:07:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vadim Nasardinov 2003-07-22 16:26:16 EDT
While the com.redhat.persistence.Session class and its flushAll()
method are both public, there is no sanctioned way to get the
session object that I am aware of.  This is by design.

However, the versioning event processor needs to be able to
call ssn.flushAll().  This is needed in order to correctly
support the methods suspendVersioning() and resumeVersioning().

suspendVersioning() must flush all pending events before turning
versioning off.

Likewise, resumeVersioning() must flush all pending events before
turning versioning back on.
Comment 1 Vadim Nasardinov 2003-07-24 10:34:12 EDT
I see that the flushAll() method was added to com.redhat.persistence.Session 
in changelist 33910. 
 
The question remains, how do I get the session object?  
SessionManager.getSession() returns com.arsdigita.persistence.Session -- 
not com.redhat.persistence.Session. 
 
 
Comment 2 Vadim Nasardinov 2003-07-24 10:50:56 EDT
never mind

this can be closed

Note You need to log in before you can comment on or make changes to this bug.