Bug 1004833 - Wrong role of user after migration to satellite 5.6 (postgresql)
Wrong role of user after migration to satellite 5.6 (postgresql)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Zázrivec
Pavel Studeník
:
Depends On:
Blocks: sat560-upgrades
  Show dependency treegraph
 
Reported: 2013-09-05 10:57 EDT by Pavel Studeník
Modified: 2013-10-01 15:26 EDT (History)
0 users

See Also:
Fixed In Version: rhn-upgrade-5.6.0.31-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 15:26:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Studeník 2013-09-05 10:57:09 EDT
Description of problem:
I upgraded satellite 5.4.1 with external oracle to satellite 5.6 and I migrated satellite with same data on postgresql. I compared data by spacewalk-report and I got different result in users. 

postgre:
> ...,Organization Administrator;Satellite Administrator,2008-12-09 13:15:58,,enabled
oracle:
< ...,Organization Administrator,2008-12-09 12:15:58,,enabled

Some users have different role on satellite with postgresql.

Version-Release number of selected component (if applicable):
Satellite-5.6.0-RHEL6-re20130830.0-x86_64.iso

How reproducible:
allways with customer's db

Steps to Reproduce:
1. install.pl --external-oracle --upgrade
2. spacewalk-report users > users.oracle.cvs
3. install.pl --upgrade
4. spacewalk-report users > users.pg.cvs
5. diff users.pg.cvs users.oracle.cvs

Actual results:
different data

Expected results:
same data
Comment 3 Clifford Perry 2013-10-01 15:26:22 EDT
Satellite 5.6 has been released. This bug tracked under Upgrades. 

This bug either was VERIFIED or RELEASE_PENDING (re-verified prior shortly before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1393.html

Note You need to log in before you can comment on or make changes to this bug.