Bug 1004837 - Once deleted, the ISO storage can't be added with the same IP but can with the FQDN.
Once deleted, the ISO storage can't be added with the same IP but can with th...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.4.0
Assigned To: Daniel Erez
Aharon Canan
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 11:04 EDT by Bill Sanford
Modified: 2016-02-10 13:03 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-23 01:36:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: Triaged+


Attachments (Terms of Use)
This is the engine.log file that shows the fails of the ISO storage. (4.18 MB, text/x-log)
2013-09-05 11:04 EDT, Bill Sanford
no flags Details

  None (edit)
Description Bill Sanford 2013-09-05 11:04:53 EDT
Created attachment 794305 [details]
This is the engine.log file that shows the fails of the ISO storage.

Description of problem:
I have configured a data center to have an imported ISO domain with an IP address and path after the ISCSI storage was added. I then put the ISO domain in maintenance mode, detached the ISO and then deleted it.

At this time, the only storage that is showing, is the ISCSI storage. 

I then try to add the same ISO storage with the same IP address and RHEV-M says it already exists and still no sign of it in the GUI. I *then* add the exact same ISO, but instead of using the IP address, I use the FQDN. This imports the ISO domain, correctly. 

Version-Release number of selected component (if applicable):
RHEV-M 3.3 (is12)

How reproducible:
100%

Steps to Reproduce:
1. See above.
2.
3.

Actual results:
ISO storage fails to get added to RHEV-M

Expected results:
ISO storage succeeds to get added to RHEV-M

Additional info:
Comment 1 Ayal Baron 2013-09-12 06:15:49 EDT
Allon, this looks like a duplicate of the remaining connection bug.
Comment 2 Allon Mureinik 2013-09-18 05:03:31 EDT
Ayal, you are referring to bug 991470.
It's similar, but not exactly identical - removing a domain from the GUI, with no errors, SHOULD also remove the connection record.
Comment 3 Daniel Erez 2014-04-13 04:29:44 EDT
(In reply to Allon Mureinik from comment #2)
> Ayal, you are referring to bug 991470.
> It's similar, but not exactly identical - removing a domain from the GUI,
> with no errors, SHOULD also remove the connection record.

According to the logs, it seems like a duplicate of bug 1020812 which has been resolved for 3.3. The described scenario doesn't appear to reproduce any longer. Moving to ON_QA for re-verification (please note that 'Format Domain' option should be checked in order to completely remove the ISO domain).
Comment 4 Aharon Canan 2014-04-22 06:16:32 EDT
Derez, 

This one was opened for 3.3 which means it reproduce in 3.3
If it is the same then the original is not fixed.
if it is not please fix.
Comment 5 Allon Mureinik 2014-04-23 01:36:12 EDT
This bug was reported on RHEVM 3.3 is12. Bug 1020812 was fixed in is23. Closing.

Note You need to log in before you can comment on or make changes to this bug.