Bug 1004875 - Request: Change mod_jk-ap22's dependencies
Request: Change mod_jk-ap22's dependencies
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: RPMs (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity unspecified
: DR6
: EAP 6.3.0
Assigned To: Permaine Cheung
Michal Karm Babacek
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 12:00 EDT by Michal Karm Babacek
Modified: 2015-02-20 05:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-28 11:25:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Karm Babacek 2013-09-05 12:00:56 EDT
Hello :-)

yum install mod_jk forces customers on RHEL6 (RHEL5) to update their httpd
from 2.2.15 (2.2.3) to 2.2.22 from jbappplatform-6 channel. This is not
the desired behaviour.

Please, edit mod_jk's spec file [1] in this fashion (and check my somewhat
feeble spec file syntax knowledge :-))


- Requires: httpd >= 2.2.22
+ #RHEL5 specific:
+ %if 0%{?rhel} == 5
+   Requires: httpd >= 2.2.3
+   Requires: mod_perl >= 2.0.4
+ #RHEL6 specific:
+ %else
+   Requires: httpd >= 2.2.15
+ %endif 


Note
----
Yes, httpd 2.2.3 is a supported httpd version (needs mod_perl though).
Yes, httpd 2.2.15 is a supported httpd version.
Yes, mod_perl is necessary due to:

    readelf -Ws /etc/httpd/modules/mod_jk.so | grep ap_get_server_description
    21: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND ap_get_server_description

that is satisfied by:

    readelf -Ws /etc/httpd/modules/mod_perl.so | grep ap_get_server_description
    410: 000000000002a5f0     5 FUNC    GLOBAL DEFAULT   10 ap_get_server_description

We test this setup during the regular test cycle.
Latter httpd 2.2.15 provides the symbol itself and does not require mod_perl installed.



[1] http://pkgs.devel.redhat.com/cgit/rpms/mod_jk/tree/mod_jk.spec?h=jb-eap-6-rhel-6
Comment 1 Permaine Cheung 2013-09-09 12:04:28 EDT
These new builds contain the requested changes:
mod_jk-1.2.37-3.redhat_2.ep6.el6
mod_jk-1.2.37-3.redhat_2.ep6.el5
Comment 3 Michal Karm Babacek 2014-03-31 09:50:33 EDT
Verified, spec is O.K. and installation looks fine as well:

RHEL6
Installed: httpd-2.2.15-29.el6_4.x86_64.rpm
Package mod_jk-ap22.x86_64 0:1.2.37-4.redhat_3.ep6.el6 does not require httpd upgrade nor mod_perl.

RHEL5
Installed: httpd-2.2.3-83.el5_10.x86_64.rpm                                                                                               
Package mod_jk-ap22-1.2.37-4.redhat_3.ep6.el5.x86_64.rpm does not require httpd upgrade and it depends on:
mod_perl-2.0.4-6.el5.x86_64.rpm, which needs perl-BSD-Resource-1.28-1.fc6.1.x86_64.rpm.

VERIFIED

Note You need to log in before you can comment on or make changes to this bug.