Bug 1004876 - idlistscanlimit per index/type/value
idlistscanlimit per index/type/value
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rich Megginson
Sankar Ramalingam
:
Depends On:
Blocks: 1011539 1061410
  Show dependency treegraph
 
Reported: 2013-09-05 12:02 EDT by Nathan Kinder
Modified: 2014-10-14 03:50 EDT (History)
3 users (show)

See Also:
Fixed In Version: 389-ds-base-1.2.11.15-34.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1011539 (view as bug list)
Environment:
Last Closed: 2014-10-14 03:50:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan Kinder 2013-09-05 12:02:50 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/47504

With very large databases, some queries go through a lot of work to build huge ID lists for filter components with many matching IDs.  For example, a search for (&(objectclass=inetorgperson)(uid=foo)) may build a huge idlist for objectclass=inetorgperson only to throw it away to intersect it with uid=foo.  In these cases, it would be useful to be able to tell the indexing code to use a different idlistscanlimit for certain indexes, or use no idlist at all.  In the above case, it would be useful to tell the indexing code to skip building an idlist for objectclass=inetorgperson, but still use the default idlistscanlimit for other objectclass searches (e.g. objectclass=groupOfNames).

This would also help in https://fedorahosted.org/389/ticket/47474 - if there are several million IDs for each of the objectclass= filter components, being able to skip id list generation for the objectclass values would make that query very fast.

We can't reuse nsslapd-idlistscanlimit, so perhaps a new attribute

dn: cn=attrname,cn=index,...
objectclass: nsIndex
nsIndexIDSize: NNNN[:type][:eqvalue:eqvalue:...]

Where NNNN is the max ID list size (or 0 for no list at all)
type is the type of index (sub, pres, eq)
eqvalue are for equality indexes - these are the values to which the max ID list size applies

So in the case of ticket/47474, something like

dn: cn=objectclass,...
objectclass: nsIndex
nsIndexType: eq
nsIndexIDSize: 0:eq:organizationalPerson:inetOrgPerson:organization:organizationalUnit:groupOf
Names:groupOfUniqueNames:group

Would effectively disable id list generation for the objectclass values listed.

Note that this will apply to _all_ queries for any of the objectclass values, not just their use in conjunction with this particular search filter.
Comment 1 Rich Megginson 2014-01-22 14:35:40 EST
ported all tests to tet rhel 6.6

------------------------------------------------------------------------
r8285 | rmeggins@REDHAT.COM | 2014-01-22 12:30:31 -0700 (Wed, 22 Jan 2014) | 9 l
ines

Tests for the new feature Fine Grained ID List Size
new file filterscanlimit.sh tests have many positive and
negative tests to test features and error handling
tests pass with valgrind reporting no errors
upstream ticket - https://fedorahosted.org/389/ticket/47504
rhel 7.0 bz - https://bugzilla.redhat.com/show_bug.cgi?id=1011539
rhel 6.x bz - https://bugzilla.redhat.com/show_bug.cgi?id=1004876
Comment 4 Amita Sharma 2014-06-25 06:15:44 EDT
Automated test cases in TET for filter test suites are PASSing. Hence, marking the bug as Verified.

Build tested -[svrbld@dhcp201-155 6.0]$ rpm -qa | grep 389
389-ds-base-libs-1.2.11.15-36.el6.x86_64
389-ds-base-debuginfo-1.2.11.15-36.el6.x86_64
389-adminutil-1.1.17-1.el6.x86_64
389-ds-base-1.2.11.15-36.el6.x86_64
 

Snippets from the acceptance test report

TestCase [fsl1] result-> [PASS]
PASS : Test case for bug1004876, which is automated as fsl1
Test fsl2 - test various combinations of filters and idlistscanlimit
Starting...test cases for bug1004876, fsl2
loaded index config from /RHEL66/tet/../data/DS/6.0/filter/en/fslindexconfig.ldif
modifying entry cn=config

TestCase [fsl2] result-> [PASS]
PASS : Test case for bug1004876, which is automated as fsl2
Cleanup for the Fine Grained Indexing test ...
RemoveInstance /usr/lib64/dirsrv/slapd-fsl 10002
Instance slapd-fsl removed.
successfully removed slapd-fsl
TestCase [fsl_cleanup] result-> [PASS]

Hence marking VERIFIED.
Comment 5 errata-xmlrpc 2014-10-14 03:50:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1385.html

Note You need to log in before you can comment on or make changes to this bug.